Crash with floated generated content [@ nsCachedStyleData::GetStyleData] called from nsRuleNode::ComputeDisplayData

RESOLVED WORKSFORME

Status

()

Core
Layout
--
critical
RESOLVED WORKSFORME
12 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

(Blocks: 1 bug, {crash, testcase})

Trunk
PowerPC
Mac OS X
crash, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
Loading the testcase makes Firefox trunk crash on Mac.  In a debug build, I see this assertion before the crash:

###!!! ASSERTION: Must have parent context for generated content: '!generatedContent || parentContext', file mozilla/layout/style/nsRuleNode.cpp, line 2628

ispiked found this bug on Linux; I only helped make a reduced testcase.
(Reporter)

Comment 1

12 years ago
Created attachment 227636 [details]
small testcase
(Reporter)

Comment 2

12 years ago
Created attachment 227638 [details]
stack trace (mac debug / gdb)

Comment 3

12 years ago
this appears to be the most common crash in the test run for random classes for 20060629 windows firefox trunk.
(Reporter)

Updated

12 years ago
Blocks: 331889
*** Bug 343608 has been marked as a duplicate of this bug. ***
The duplicate bug 343608 has a regression range, pointing to bug 332333.
(Reporter)

Comment 6

12 years ago
Nominating because this crash gets in the way of my testing.
Flags: blocking1.9a1?
(Reporter)

Comment 7

12 years ago
WFM:

* 2006-08-11 Mac trunk nightly crashes.
* 2006-08-12 Mac trunk nightly does not crash.
* A reasonably current Mac trunk debug build does not crash or assert.

Perhaps this was fixed by bz's patch for bug 334602?  (That bug happens to have a bug number that is a permutation of this one.)
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Yeah, this got fixed by the patch for bug 334602.  The permutation is a random coincidence.  ;)
Depends on: 334602
Flags: blocking1.9a1?

Comment 9

12 years ago
(In reply to comment #8)
>The permutation is a random coincidence.  ;)
As opposed to a deliberate coincidence? :-P
Group: security
(Reporter)

Comment 10

10 years ago
Crashtest checked in.
Flags: in-testsuite+
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsCachedStyleData::GetStyleData]
You need to log in before you can comment on or make changes to this bug.