make it easy to change event title after creating the event via mouse dragging

VERIFIED FIXED in Sunbird 0.5

Status

Calendar
Sunbird Only
--
enhancement
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: Damian Szczepanik, Assigned: Joey Minta)

Tracking

Sunbird 0.3a2
Sunbird 0.5

Details

Attachments

(1 attachment)

5.22 KB, patch
Matthew (lilmatt) Willis
: first-review+
Michiel van Leeuwen (email: mvl+moz@)
: second-review+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060706 Sunbird/0.3a2+

When I create new event (using mouse dragging) I got new evnet with title="New Event"
I would like to have easily way to modify title, much more easier than use mouse and open event or click event in main view to make it editable

Reproducible: Always

Steps to Reproduce:
1. move mouse over main view (month view)
2. press mouse
3. move down
4. release mouse
Actual Results:  
New event with title "New Event" was created

Expected Results:  
create event and open event dialog to set title manually
or
make event editable

Well this is small thing however if you create new event you always have to change predefined title from "New event" to something useful and this suggestion inprove this.
To have predefined title like "New Evnet" is quite strange, because it is useless...

thanks
(Reporter)

Updated

12 years ago
Version: unspecified → Sunbird 0.3a2
Changing the title to describe the actual problem, instead of a possible solution.

A different solution (one that I like better so far) is to select the text, so that you can start to type the new title right after creating the event. No need to search a rather complex dialog for the field you want to change.

Summary: open event dialog when create event via mouse dragging → make it easy to change event title after creating the event via mouse dragging
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> A different solution (one that I like better so far) is to select the text, so
> that you can start to type the new title right after creating the event. No
> need to search a rather complex dialog for the field you want to change.

Could you provide more details - I do not get the point...

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 3

11 years ago
Created attachment 235465 [details] [diff] [review]
start editing immediately

This patch does what mvl described in comment #1.  After dragging to create a new event, we immediately start editing the title, so the title can be easily changed.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #235465 - Flags: second-review?(dmose)
Attachment #235465 - Flags: first-review?(mattwillis)
Comment on attachment 235465 [details] [diff] [review]
start editing immediately

r1=lilmatt
Attachment #235465 - Flags: first-review?(mattwillis) → first-review+
*** Bug 357334 has been marked as a duplicate of this bug. ***
Comment on attachment 235465 [details] [diff] [review]
start editing immediately

dmose is on vaca. r2 over to mvl
Attachment #235465 - Flags: second-review?(dmose) → second-review?(mvl)
OS: Windows XP → All
Hardware: PC → All
Whiteboard: [patch in hand][needs review mvl]
Target Milestone: --- → Sunbird 0.5
Comment on attachment 235465 [details] [diff] [review]
start editing immediately

r2=mvl
Attachment #235465 - Flags: second-review?(mvl) → second-review+
Whiteboard: [patch in hand][needs review mvl] → [patch in hand][needs checkin]
Hand-merged patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Whiteboard: [patch in hand][needs checkin]
(Reporter)

Comment 9

11 years ago
As I mentioned I expect that Edit Event dialog will fire and from/to date will be set instead of editing title "inline" because right now I can modify only title. When Edit dialog is open I can use tab to move to another fields like location and press enter to accept changes.

verified with
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061124 Calendar/0.4a1
Status: RESOLVED → VERIFIED
Whiteboard: [litmus testcase wanted]
(Reporter)

Comment 10

11 years ago
Litmus testcase 3006 created
Whiteboard: [litmus testcase wanted]
You need to log in before you can comment on or make changes to this bug.