Google Reader is broken

VERIFIED FIXED in mozilla1.8.1beta2

Status

()

P1
normal
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: uriber, Assigned: mrbkap)

Tracking

({regression, testcase, verified1.8.1})

Trunk
mozilla1.8.1beta2
regression, testcase, verified1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch], URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
Google Reader is broken in the 2006-07-08 trunk nightly (only the header shows up, without the actual content). I get the following in the Error Console:

Error: _AC_SimpleStore.inherits is not a function
Source File: http://www.google.com/reader/ui/3767353430-main.js
Line: 46

Error: this.Pa is not a function
Source File: http://www.google.com/reader/ui/3767353430-main.js
Line: 889

Regression is between 2006-07-07-05 and 2006-07-08-08:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-07-07+04%3A00&maxdate=2006-07-08+09%3A00&cvsroot=%2Fcvsroot

Perhaps bug 343417 has something to do with it?

Filing as UNCONFIRMED since I don't know the component and don't have a testcase.
(Reporter)

Updated

12 years ago
OS: Mac OS X 10.3 → Mac OS X 10.4
Version: unspecified → Trunk
(Reporter)

Comment 1

12 years ago
Created attachment 228547 [details]
testcase

If you don't see the "passed" alert box, it failed ("foo.inherit is not a function").
(Reporter)

Updated

12 years ago
Keywords: testcase
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060708 Minefield/3.0a1
Loading of the site broke between 1.9a1_2006070714 and 1.9a1_2006070716.
(Reporter)

Comment 3

12 years ago
(In reply to comment #2)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060708
> Minefield/3.0a1
> Loading of the site broke between 1.9a1_2006070714 and 1.9a1_2006070716.
> 

This is consistent with bug 343417.
Blocks: 343417
(Reporter)

Updated

12 years ago
OS: Mac OS X 10.4 → All
Hardware: Macintosh → All

Comment 4

12 years ago
Google Calendar is also broken:

Error: e.bind is not a function
Source File: http://www.google.com/calendar/20060706173904doozercompiled_en.js
Line: 22

Error: _SR_genRegularTop is not a function
Source File: http://www.google.com/calendar/render?pli=1
Line: 92

Error: _GenerateTopFrame is not a function
Source File: http://www.google.com/calendar/render?pli=1
Line: 96
(Reporter)

Updated

12 years ago
Blocks: 344020
(Reporter)

Comment 5

12 years ago
Since we have a testcase and a likely regression candidate, confirming this in that bug's component (Core/XPConnect).
Status: UNCONFIRMED → NEW
Component: General → General
Ever confirmed: true
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Updated

12 years ago
Component: General → XPConnect
Assignee: nobody → dbradley
QA Contact: general → xpconnect
*** Bug 344052 has been marked as a duplicate of this bug. ***
Assignee: dbradley → general
Component: XPConnect → JavaScript Engine
QA Contact: xpconnect → general

Comment 7

12 years ago
see also bug 344120 which was also from reader.google.com, but the testcase is different (same source file, i recognize the bits).
Created attachment 228762 [details] [diff] [review]
Proposed fix

jst couldn't remember why exactly he had that JS_ClearScope there, but it was confusing the JS engine. In brief, what was happening was that the first JS_ClearScope was clearing everything, then, after we initialized the outer window (and the global window), we were calling JS_ClearScope *again*. Then, someone forced a Function object to be created on the outer window, but that caused the JS engine to define a 'Function' property on it. By this time, we had started forwarding property sets to the inner window, and since we'd already initialized the Function class on the inner window, the set was overriding that property, causing Function to refer to the outer window's function. jst and I believe that property lookup forwarding should take the place of this JS_ClearScope.
Assignee: general → mrbkap
Status: NEW → ASSIGNED
Attachment #228762 - Flags: superreview?(brendan)
Attachment #228762 - Flags: review?(jst)
Priority: -- → P1
Whiteboard: [patch]
Target Milestone: --- → mozilla1.8.1beta2
Comment on attachment 228762 [details] [diff] [review]
Proposed fix

Cite this bug just for convenience?  sr=me pending jst's r+.

/be
Attachment #228762 - Flags: superreview?(brendan) → superreview+
Comment on attachment 228762 [details] [diff] [review]
Proposed fix

r=jst
Attachment #228762 - Flags: review?(jst) → review+
Fix checked into trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Verified FIXED using both local and online testcases here; also, Netflix was broken in that it wouldn't let you rate its movies.  That too has been fixed.

Build ID: 2006-07-11-17, Windows XP SeaMonkey trunk.
Status: RESOLVED → VERIFIED

Comment 14

12 years ago
Checking in regress-343966.js;
/cvsroot/mozilla/js/tests/js1_5/Regress/regress-343966.js,v  <--  regress-343966.js
initial revision: 1.1
Flags: in-testsuite+
Comment on attachment 228762 [details] [diff] [review]
Proposed fix

This is eneded as a companion for bug 343417.
Attachment #228762 - Flags: approval1.8.1?
Comment on attachment 228762 [details] [diff] [review]
Proposed fix

a=drivers. Please land on the MOZILLA_1_8_BRANCH along with attachment 228477 [details] [diff] [review].
Attachment #228762 - Flags: approval1.8.1? → approval1.8.1+
Fix checked into the 1.8 branch.
Keywords: fixed1.8.1

Comment 18

12 years ago
verified fixed 1.8, 1.9 windows/mac(ppc|tel)/linux 20060728
Keywords: fixed1.8.1 → verified1.8.1

Comment 19

12 years ago
Was this ever landed on the MOZILLA_1_8_BRANCH ?  I'm not seeing it.  In my case, I'm seeing this bug on a MOZILLA_1_8_BRANCH build, but only in chrome, not in web pages.

Comment 20

12 years ago
Steve, could you please file another bug with steps to reproduce, a testcase, etc. and CC me, ispiked? Thanks.

Comment 21

12 years ago
Filed as bug 350655
You need to log in before you can comment on or make changes to this bug.