Closed Bug 344021 Opened 15 years ago Closed 15 years ago

line breaks not displayed in alert dialog

Categories

(Core :: DOM: Core & HTML, defect)

1.8 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: martin.honnen, Unassigned)

References

()

Details

(Keywords: regression, verified1.8.1)

With Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060708 BonEcho/2.0b1 here on Windows XP line breaks are not displayed in alert dialogs. Instead everything is rendered on one line in the alert dialog window.

It works fine with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4.

So this looks like a regression in the 1.8.1/Firefox 2.0 branch.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060708 Minefield/3.0a1
Not in branch but in trunk I see them.
The line breaks are displayed with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060625 BonEcho/2.0a3 so the regression has occured after 2006-06-25.
The regression range here is between 2006-07-06 03:00 and 2006-07-07 06:38, so I think this is most likely a regression from bug 317334.

http://bonsai.mozilla.org/cvsquery.cgi?branch=MOZILLA_1_8_BRANCH&branchtype=match&date=explicit&mindate=2006-07-06+03%3A00&maxdate=2006-07-07+06%3A38

This does however work on the trunk... perhaps |white-space: -moz-pre-wrap;| doesn't work on the branch, for some reason?
Blocks: 344045
*** Bug 344045 has been marked as a duplicate of this bug. ***
No longer blocks: 344045
Ok, this is fixed now with the back out of the patch from bug 317334 out of the 1.8.1 branch.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Verified fixed.
Testcase works again as expected (with linebreaks), using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 BonEcho/2.0b1

Also, I've looked at the 1_8_1 changelog, that I've backed out correctly:
http://tinderbox.mozilla.org/bonsai/cvsquery.cgi?module=AviarySuiteBranchTinderbox&branch=MOZILLA_1_8_BRANCH&cvsroot=/cvsroot&date=explicit&mindate=1152482918&maxdate=1152483060&who=martijn.martijn%25gmail.com
Status: RESOLVED → VERIFIED
verified fixed 1.8.1 20060710 bonecho winxp/macosxppc
You need to log in before you can comment on or make changes to this bug.