Lightning doesn't work in Thunderbird 1.5.0.x anymore

VERIFIED FIXED

Status

Calendar
Lightning Only
--
critical
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: ssitter, Assigned: dbo)

Tracking

({fixed1.8.1})

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
Lightning won't work in Thunderbird 1.5.0.x anymore. This started with 2006-07-07 Lightning win32 mozilla1.8 branch build. During startup you see a lot of errors (see below). It's not possible to do basic tasks like switching to calendar view.

The same Lightning xpi works fine in official Thunderbird 2.0a1:

Thunderbird 1.5.0.5 (20060709) + Lightning 0.1+ (20060709) --> don't work
Thunderbird 2.0a1 (20060709) + Lightning 0.1+ (20060709) --> work

Because of this I don't think this is a problem with the tinderbox config (e.g. Bug 330753).

Maybe this is caused by the JS1.7 landing on MOZILLA_1_8_BRANCH on 2006-07-06 evening?

Errors in JavaScript Console:

Error: uncaught exception: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: chrome://calendar/content/calendarUtils.js :: <TOP_LEVEL> :: line 89"  data: no]

Error: uncaught exception: [Exception... "Invalid ClassID or ContractID"  nsresult: "0x80570017 (NS_ERROR_XPC_BAD_CID)"  location: "JS frame :: chrome://lightning/content/lightning-utils.js :: <TOP_LEVEL> :: line 44"  data: no]

Error: prefService has no properties
Source File: chrome://calendar/content/calendar-decorated-week-view.xml Line: 277

Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://lightning/content/messenger-overlay-sidebar.js :: ltnOnLoad :: line 165"  data: no]
Source File: chrome://lightning/content/messenger-overlay-sidebar.js Line: 165

Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: chrome://lightning/content/lightning-utils.js :: ltnGetService :: line 22"  data: no]
Source File: chrome://lightning/content/lightning-utils.js Line: 22

Error: CalDateTime is not a constructor
Source File: chrome://lightning/content/agenda-tree.js Line: 381

...

Updated

12 years ago
Summary: Lightning don't work in Thunderbird 1.5.0.x anymore → Lightning doesn't work in Thunderbird 1.5.0.x anymore
(Reporter)

Comment 1

12 years ago
*** Bug 344345 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

12 years ago
We are using a Lightning build from 1.8 branch and use it with a Thunderbird build from 1.8.0 branch.

I checked the Lightning *.dll files and see the following error when viewing dependencies of calbscmp.dll:

Error: At least one module has an unresolved import due to a missing export function in an implicitly dependent module:
 [   ] c:\lightning-2006-07-10-06-mozilla1.8\components\CALBSCMP.DLL
     [ E ] c:\thunderbird-1.5.0.5.en-us.win32\thunderbird\XPCOM_CORE.DLL
          [CE ]    N/A  1530 (0x05FA)  @PL_DHashTableOperate@12


The implementation of PL_DHashTableOperate was changed during regression range by checkin of JS1.7:
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=pldhash.c&branch=MOZILLA_1_8_BRANCH&root=/cvsroot&subdir=mozilla/xpcom/glue&command=DIFF_FRAMESET&rev1=3.1.2.4&rev2=3.1.2.5

Mozilla 1.8 branch version:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpcom/glue/pldhash.c&rev=MOZILLA_1_8_BRANCH&cvsroot=/cvsroot&mark=635#615

Mozilla 1.8.0 branch version:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpcom/glue/pldhash.c&rev=3.1.2.3&mark=578#558


I think this is the cause for the failure. Blake, can you give a comment on this assumption?
(Assignee)

Comment 3

12 years ago
Created attachment 229227 [details] [diff] [review]
rewinding __fastcall for WIN_XP in pldhash.h

PL_DHashTableOperate's calling convention has been altered incompatible to __fastcall on WinXP.
Attachment #229227 - Flags: first-review?(benjamin)

Comment 4

12 years ago
Comment on attachment 229227 [details] [diff] [review]
rewinding __fastcall for WIN_XP in pldhash.h

This is for which branch? I do want fastcall on the trunk (and we don't promise binary stability for the pldhash symbols).
(Assignee)

Comment 5

12 years ago
(In reply to comment #4)
> (From update of attachment 229227 [details] [diff] [review] [edit])
> This is for which branch? I do want fastcall on the trunk (and we don't promise
> binary stability for the pldhash symbols).

This is for MOZILLA_1_8_BRANCH/TRUNK, nevertheless we would like the very same binary being runnable on 1.5.0.x, if possible [with workarounds], avoiding a separate release.
So IMO the only option left is to revise base/src/calICSService making no use of nsXXXHashtable.h. Are there alternative C++ hashtable classes available which stay compatible?

Q: Why is that hashtable API not defined to stay compatible? IMO a pretty common need.
Q: Is there a measurable impact on performance using __fastcall for that function?
(Reporter)

Updated

12 years ago
Flags: blocking0.3?(dmose)

Comment 6

12 years ago
Comment on attachment 229227 [details] [diff] [review]
rewinding __fastcall for WIN_XP in pldhash.h

r=me for the 1.8 branch only. This should not land on trunk.
Attachment #229227 - Flags: first-review?(benjamin)
Attachment #229227 - Flags: first-review+
Attachment #229227 - Flags: approval1.8.1?
Comment on attachment 229227 [details] [diff] [review]
rewinding __fastcall for WIN_XP in pldhash.h

a=mconnor on behalf of drivers for checkin by Wednesday, July 19th
Attachment #229227 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

12 years ago
Assignee: nobody → daniel.boelzle
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED

Updated

12 years ago
Flags: blocking0.3?(dmose) → blocking0.3+
(Assignee)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

12 years ago
*** Bug 345041 has been marked as a duplicate of this bug. ***
Whiteboard: [checkin needed (1.8 branch)]
(Reporter)

Comment 9

12 years ago
Patch has been checked in to MOZILLA_1_8_BRANCH, mozilla/xpcom/glue/pldhash.h rev. 3.1.2.6 on 2006-07-17 by daniel.boelzle@sun.com.
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
(Reporter)

Comment 10

12 years ago
VERIFIED with Thunderbird/1.5.0.5 (20060719) and Lightning/0.1+ (2006090112)
VERIFIED with Thunderbird/1.5.0.7 (20060901) and Lightning/0.1+ (2006090112)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.