Create Web Pages for Moz Report Phishing

RESOLVED FIXED

Status

RESOLVED FIXED
13 years ago
6 years ago

People

(Reporter: sherman, Assigned: sherman)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: also need to pass the url along to Google, see comment 4)

Attachments

(3 attachments, 1 obsolete attachment)

(Assignee)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1
Build Identifier: 

Create web pages hosted on mozilla.org for reporting a phishing site.  The user will be directed to these pages, which will instruct the user to click over to Google to report the site.  

This bug supports the changes made at: 
https://bugzilla.mozilla.org/show_bug.cgi?id=344063


Reproducible: Always
(Assignee)

Updated

13 years ago
Depends on: 344063
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

13 years ago
Submitting web page text for comments/review:

http://www.mozilla.org/projects/bonecho/anti-phishing/report_general/
------------------------------------------------------------
The Phishing Protection feature in Firefox uses data provided by Google to help identify potential Web forgeries.

If you believe that you've encountered a misleading website but don't see the "Suspected Web Forgery" warning, or you do see the warning for a site that isn't actually a web forgery, please click <a href="http://www.mozilla.org/projects/bonecho/anti-phishing/report_general/&url=http%3A%2F%2Fwww.google.com%2Ftools%2Ffirefox%2Fsafebrowsing%2Fphish-o-rama.html">here</a> to report the site to Google.  



http://www.mozilla.org/projects/bonecho/anti-phishing/report_error/
------------------------------------------------------------
The Phishing Protection feature in Firefox uses data provided by Google to help identify potential Web forgeries.  

If you believe that Phishing Protection is warning users of misleading activity on what is actually a safe page, please click <a href="http://www.mozilla.org/projects/bonecho/anti-phishing/report_error/&url=http%3A%2F%2Fwww.google.com%2Ftools%2Ffirefox%2Fsafebrowsing%2Fphish-o-rama.html">here</a> to report the error to Google. They値l act quickly to address any possible errors.



http://www.mozilla.org/projects/bonecho/anti-phishing/report_phish/
------------------------------------------------------------
The Phishing Protection feature in Firefox uses data provided by Google to help identify potential Web forgeries.

If you believe you've encountered a page designed to look like another page in an attempt to steal users' personal information, please click <a href="http://www.mozilla.org/projects/bonecho/anti-phishing/report_phish/&hl=en-US&url=http%3A%2F%2Fwww.google.com%2Ftools%2Ffirefox%2Fsafebrowsing%2Fphish-o-rama.html">here</a> to report the page to the Google.
(Assignee)

Comment 2

13 years ago
Let's try this again with the correct Google URLs:

http://www.mozilla.org/projects/bonecho/anti-phishing/report_general/
------------------------------------------------------------
The Phishing Protection feature in Firefox uses data provided by Google to help
identify potential Web forgeries.

If you believe that you've encountered a misleading website but don't see the
"Suspected Web Forgery" warning, or you do see the warning for a site that
isn't actually a web forgery, please click <a
href="http://www.google.com/safebrowsing/report_general/?continue=http%3A%2F%2Fwww.google.com%2Ftools%2Ffirefox%2Fsafebrowsing%2Fsubmit_success.html">here</a>
to report the site to Google.  



http://www.mozilla.org/projects/bonecho/anti-phishing/report_error/
------------------------------------------------------------
The Phishing Protection feature in Firefox uses data provided by Google to help
identify potential Web forgeries.  

If you believe that Phishing Protection is warning users of misleading activity
on what is actually a safe page, please click <a
href="http://www.google.com/safebrowsing/report_error/?continue=http%3A%2F%2Fwww.google.com%2Ftools%2Ffirefox%2Fsafebrowsing%2Fsubmit_success.html">here</a>
to report the error to Google. They値l act quickly to address any possible
errors.



http://www.mozilla.org/projects/bonecho/anti-phishing/report_phish/
------------------------------------------------------------
The Phishing Protection feature in Firefox uses data provided by Google to help
identify potential Web forgeries.

If you believe you've encountered a page designed to look like another page in
an attempt to steal users' personal information, please click <a
href="http://www.google.com/safebrowsing/report_phish/?continue=http%3A%2F%2Fwww.google.com%2Ftools%2Ffirefox%2Fsafebrowsing%2Fsubmit_success.html">here</a>
to report the page to the Google.
(Assignee)

Comment 3

13 years ago
Created attachment 228816 [details]
Modified key-point DIV for report phishing pages
We need to use some JS to capture the URL field that will be passed to us, and pass it along to Google.

We get it as:

http://www.mozilla.org/projects/bonecho/anti-phishing/report_phish/?&hl=en-US&url=http%3A%2F%2Fwww.foo.com/index.html

the "hl" parameter is the language code, we can drop it for now
the "url" parameter is the submitted URL, we should forward that to the google links as the exact same parameter
(Assignee)

Comment 5

13 years ago
Created attachment 228881 [details] [diff] [review]
Updated html for report_general
Attachment #228816 - Attachment is obsolete: true
(Assignee)

Updated

13 years ago
Attachment #228881 - Attachment description: Updated htmle for report_general → Updated html for report_general
(Assignee)

Comment 6

13 years ago
Created attachment 228882 [details] [diff] [review]
Updated html for report_error
(Assignee)

Comment 7

13 years ago
Created attachment 228883 [details] [diff] [review]
Updated html for report_phish
(Assignee)

Comment 8

13 years ago
Comment on attachment 228881 [details] [diff] [review]
Updated html for report_general

Submitting for review.
Attachment #228881 - Flags: review?(cbeard)
(Assignee)

Updated

13 years ago
Attachment #228882 - Flags: review?(cbeard)
(Assignee)

Updated

13 years ago
Attachment #228883 - Flags: review?(cbeard)

Updated

13 years ago
Attachment #228881 - Flags: review?(cbeard) → review+

Comment 9

13 years ago
Comment on attachment 228882 [details] [diff] [review]
Updated html for report_error

a=cbeard, minor nit is that we use "Bon Echo" in a few places, that should be "Firefox 2 Beta 1" but that's not a show stopper
Attachment #228882 - Flags: review?(cbeard) → review+

Updated

13 years ago
Attachment #228883 - Flags: review?(cbeard) → review+

Comment 10

13 years ago
also, the logo show be the firefox logo instead of the default globe icon.  we'll want to revisit the wording for b2 to ensure consistency in terminology as well, "phishing site" vs. "forgery", "possible scame", etc.
(In reply to comment #9)
> (From update of attachment 228882 [details] [diff] [review] [edit])
> "Firefox 2 Beta 1" but that's not a show stopper

Reed's checking these in. Reed, as you do so, can you s/Bon Echo/Firefox 2/ for these pages? Also, the:

<li><a href="../">Back to Bon Echo Page</a></li>

should be

<li><a href="../">Phishing Protection FAQ</a></li>

for all of these pages
Checking in report_error/index.html;
/cvsroot/mozilla-org/html/projects/bonecho/anti-phishing/report_error/index.html,v  <--  index.html
new revision: 1.2; previous revision: 1.1
done
Checking in report_general/index.html;
/cvsroot/mozilla-org/html/projects/bonecho/anti-phishing/report_general/index.html,v  <--  index.html
new revision: 1.2; previous revision: 1.1
done
Checking in report_phish/index.html;
/cvsroot/mozilla-org/html/projects/bonecho/anti-phishing/report_phish/index.html,v  <--  index.html
new revision: 1.2; previous revision: 1.1
done

Since I don't have the new Firefox 2 image yet, I just used the old deerpark one. Once steven gets the new image, I'll add it and change it on all the pages.
Assignee: nobody → sherman
Status: NEW → ASSIGNED
Should the "Bon Echo" on http://www.mozilla.org/projects/bonecho/anti-phishing/ be changed to "Firefox 2" also?
(In reply to comment #13)
> Should the "Bon Echo" on http://www.mozilla.org/projects/bonecho/anti-phishing/
> be changed to "Firefox 2" also?

Checking in mozilla-org/html/projects/bonecho/anti-phishing/index.html;
/cvsroot/mozilla-org/html/projects/bonecho/anti-phishing/index.html,v  <--  index.html
new revision: 1.6; previous revision: 1.5
done

Updated

13 years ago
Whiteboard: also need to pass the url along to Google, see comment 4
The rest of this bug will be fixed in bug 344551.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: mozilla.org → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.