Last Comment Bug 344312 - Blank help pages for 20 locales
: Blank help pages for 20 locales
Status: RESOLVED WORKSFORME
: regression, relnote
Product: Mozilla Localizations
Classification: Client Software
Component: Other (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Axel Hecht [pto-Aug-30][:Pike]
:
Mentors:
Depends on: 324968 350488
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-11 17:33 PDT by Tim Riley [:timr]
Modified: 2006-09-11 02:15 PDT (History)
20 users (show)
l10n: blocking‑firefox2-
See Also:
Crash Signature:
(edit)
Locale:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Tim Riley [:timr] 2006-07-11 17:33:57 PDT
The QA team did our standard L10n smoke test on the Tier 1 locales and noticed that many when we went to the Help menu item, both then main and side panel of the help winder were blank.

Axel did an LDX search and found that these 20 locales reference non-existant files.  Here is the list from Axel:

/bg/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/cs/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/da/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/de/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/en-GB/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/es-ES/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/eu/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/gu-IN/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/he/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/fy-NL/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/hu/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/hy-AM/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/ko/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/mk/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/mn/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/pa-IN/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/ro/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/sq/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/zh-TW/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/>
/pt-PT/browser/chrome/help/firebirdhelp.rdf, line 20 -- nc:datasources="firebird-glossary.rdf"/> 

Here is the LXR search string:
http://lxr.mozilla.org/l10n-mozilla1.8/search?string=firebird-glossary.rdf

This is not considered a blocker for Beta1 as the help text is not updated for the FF2 features, locales are considered Alpha level at this point, and help itself is not broken.  There are otherways to get to it (ex: chrome://browser/locale/help/cookies.xhtml)

This needs to be Release Noted!
Comment 1 Tim Riley [:timr] 2006-07-11 17:47:08 PDT
This apprears to be a regression from bug 324968 according to Axel's research.
Comment 2 Shaohua Wen 2006-07-11 17:59:04 PDT
in zh-CN locale files the data source is:
nc:datasources="chrome://help/locale/help-toc.rdf firebird-toc.rdf"/>
but The help page is EMPTY also.
Comment 3 Hasse 2006-07-12 00:44:52 PDT
I think the problem with zh-CN is that there is a section missing in its firebird-toc.rdf.
http://lxr.mozilla.org/mozilla/source/browser/locales/en-US/chrome/help/firebird-toc.rdf#428 through line 445.

The brandDTD entity in the DOCTYPE should also link to "chrome://branding/locale/brand.dtd".
Comment 4 João Neves 2006-07-12 02:48:02 PDT
Corrected for pt-PT in CVS. In our case, the reference should be to file glossary.rdf instead of firebird-glossary.rdf.
Comment 5 A S Alam 2006-07-12 21:38:22 PDT
pa-IN is updated as 
"toc" and "chrome://help/locale/help-toc.rdf firebird-toc.rdf"

thanks
Comment 6 Shaohua Wen 2006-07-17 06:36:15 PDT
(In reply to comment #3)
Thanks,zh-CN modified and problem resolved.
Comment 7 Jose Sun (Moztw.org) 2006-07-17 08:45:48 PDT
zh-TW is resolved in CVS.
Thanks.
Comment 8 Ibon Igartua 2006-07-17 14:51:09 PDT
eu fixed in CVS

many thanks!
Comment 9 Marcelo Poli 2006-08-14 10:27:08 PDT
es-AR working
Updating last minute changes.
Comment 10 Axel Hecht [pto-Aug-30][:Pike] 2006-08-14 10:56:40 PDT
Affected locales as of today are:

da, de, es-ES, fy-NL, gu-IN, he, hy-AM, mk, ro, sq.

I think we should try to get this fixed for B2. Yes, en-US help content is not final, but not showing help at all isn't the best sign of QA/testing.
Comment 11 Ankit Patel 2006-08-15 00:10:37 PDT
Gujarati (gu-IN) file is updated. Can somebody verify that whether it's correct or not.
Comment 12 Wim 2006-08-15 03:32:38 PDT
(In reply to comment #10)
> Affected locales as of today are:
> 
> da, de, es-ES, fy-NL, gu-IN, he, hy-AM, mk, ro, sq.

fy-NL committed.
Is there a way to test this locally, without waiting for a new build?
Where does firebirdhelp.rdf reside in the program?

W.
Comment 13 Søren Christensen 2006-08-15 13:00:17 PDT
(In reply to comment #10)
> Affected locales as of today are:
> 
> da, de, es-ES, fy-NL, gu-IN, he, hy-AM, mk, ro, sq.
> 
> I think we should try to get this fixed for B2. Yes, en-US help content is not
> final, but not showing help at all isn't the best sign of QA/testing.
> 

Maybe I'm the only slow translater here, but I dont even know how to fix this. A few hints please.
Comment 14 Wim 2006-08-16 00:24:08 PDT
> Maybe I'm the only slow translater here, but I dont even know how to fix this.
> A few hints please.

Edit the file firebirdhelp.rdf
W.

Comment 15 Steffen Wilberg 2006-08-16 02:36:13 PDT
Just look at the patch in bug 324968: firebird-glossary.rdf and firebird-index1.rdf have been merged into and replaced by search-db.rdf, and firebirdhelp.rdf has been updated. You need to do the same in your locale.
Comment 16 Mike Connor [:mconnor] 2006-08-16 10:47:31 PDT
Need this fixed for final, but won't block beta2
Comment 17 [:rickiees] Ricardo Palomares 2006-08-16 12:54:50 PDT
(In reply to comment #10)
> Affected locales as of today are:
> 
> da, de, es-ES, fy-NL, gu-IN, he, hy-AM, mk, ro, sq.
> 
> I think we should try to get this fixed for B2. Yes, en-US help content is not
> final, but not showing help at all isn't the best sign of QA/testing.
> 


Just uploaded es-ES. Not tested yet, though. Let's see in the next few hours if I've done it right...
Comment 18 Mike Connor [:mconnor] 2006-08-23 23:27:51 PDT
Axel, should this be split off into individual bugs against each localization where this matters?  If not, can you drive to completion?
Comment 19 Tim Riley [:timr] 2006-08-29 19:23:07 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

es-ES works for me now.  I tested this last night.

From QA testing, da and de still broken.

These are not planned for beta 2: he, hy-AM, ro, sq

So these are still in question or broken for Beta2: da, de, fy-NL, ga-IN, mk
Comment 20 Wim 2006-08-29 23:50:32 PDT
(In reply to comment #19)
> So these are still in question or broken for Beta2: da, de, fy-NL, ga-IN, mk

fy-NL was already resolved on 2006-08-15.
see comment #12.

Comment 21 Damjan Georgievski 2006-08-30 04:30:03 PDT
mk is ok
Comment 22 Søren Christensen 2006-09-01 13:38:19 PDT
Since our help files arent translated at all, I simply copy/pasted the en-US into da and committed that. Hopefully that solved it.
Comment 23 Natsagdorj Shagdar 2006-09-09 07:42:56 PDT
mn fixed in CVS

Thanks.
Comment 24 Axel Hecht [pto-Aug-30][:Pike] 2006-09-11 02:15:01 PDT
The remaining locales which don't have this fixed are he (bug 352116), hy-AM (bug 352118), ro (bug 352125), sq (bug 352129).
Each of those has other problems in terms of updating their locale, too, but doesn't block firefox 2.

Resolving this bug WORKSFORME, and minus blocking-firefox2, too.

Note You need to log in before you can comment on or make changes to this bug.