Closed Bug 344422 Opened 14 years ago Closed 14 years ago

New Quick search doesn't have "Find next", "Find previous" and other

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: didaio, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

When I type some text in web-page Quick Search tab is appeared. But it haven't "Find next", "Find previous", "Highlight all" and "Match case".

Find tab haven't "Match case" option too.

Reproducible: Always
That was done intentionally, to distinguish between the different sorts of find and their different behavior.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Component: General → Find Toolbar / FastFind
QA Contact: general → fast.find
Resolution: --- → INVALID
*** Bug 344963 has been marked as a duplicate of this bug. ***
Well they behave identical: they scroll to first occurence of searched phrase. Why hilighting is OK in one and BAD in second?
I have the same issue, it's a massive problem. always happens, quick search is completely stuffed up.
*** Bug 357815 has been marked as a duplicate of this bug. ***
(In reply to comment #5)
> I have the same issue, it's a massive problem. always happens, quick search is
> completely stuffed up.

Dude. Use Cmd/Ctrl+F to get the full find bar if you want the buttons, or Cmd/Ctrl+G to get to the next search term. FAYT is a different feature (and one meant to be optimized for keyboard use) than the Find Bar. They behave differently to things like pressing "ENTER", and users need to be aware that they're not the same thing.

Whether or not they should be unified into a single feature that has two mechanisms of activating it would be a separate bug. Pretty sure that bug exists, too.

I add also that this bug doesn't exist in Linux and OSX builds. The FindAsYouType bar is complete here.
*** Bug 358146 has been marked as a duplicate of this bug. ***
Excuse me, but you removed these buttons irresponsibly and without evaluating the consequences: now that doesn't exist anymore the checkbox Highlight o Case sensitive, there is no obvious way to use these functions with FindAsYouType, and you need to stop and restart the search with CTRL+F.

Please stop removing functionalities without figure out the needs of your users. We have a lot of concerns in our community about this problem. It looks like that you advance with a leg and move back with the other (this is the first opinion of the Italian community).
*** Bug 358150 has been marked as a duplicate of this bug. ***
i agree with comment 10.
this change is a massive decrease in usability. (see my duplicate bug 358150 comment 0)
can somebody explain the pros of the changed feature?
phil says in comment 2 that these are 2 different find mechanisms.
if so, is it possible to disable the button-less find?


i think this bug should be in core/keyboard:find as you type
For who needs to reactivate the buttons we discovered this trick (from MozillaZine):

- add to your userChrome.css file:
#FindToolbar > * {display:-moz-box}

and Giuliano Masseroni has created an extension that simply do this without editing configuration files:
http://www.extenzilla.org/show_ext.php?id=555

*** Bug 358220 has been marked as a duplicate of this bug. ***
*** Bug 358298 has been marked as a duplicate of this bug. ***
I agree with this, it's extremely annoying. I know about Ctrl+G to find next, but what about find previous and the other options? I can press Ctrl+F to change it into the normal search bar, but the normal search bar doesn't close automatically, forcing the user to use the mouse to close it.

Find as you type should bring up the normal search bar. There's absolutely no reason why it shouldn't. Users should be able to use software how they want, not how the developers decide they should be using it.
(In reply to comment #13)
 
> and Giuliano Masseroni has created an extension that simply do this without
> editing configuration files:
> http://www.extenzilla.org/show_ext.php?id=555


FAYT is now present on AMO too: https://addons.mozilla.org/firefox/extensions/

(In reply to comment #13)
> and Giuliano Masseroni has created an extension that simply do this without
> editing configuration files:
> http://www.extenzilla.org/show_ext.php?id=555

FAYT is now present on AMO too: https://addons.mozilla.org/firefox/3650/

I apologize for my previous wrong comment.

I agreewith comments 10 and 12. What`s the difference beetween ctrl+F and FAYT? It wasnot clear in comment 7...

Deffinitly it was not a good idea. In very few cases I will find the word I want with the first time I type it. With no buttons, the "find as you type" feature has no use in the majority of the cases. In the other side, there is no advantage in not to show those buttons with FAYT.

this is by far the worst Firefox2 improvement. :(

(sorry about the bad english my dictionaries doesn`t work anymore too)
and I don`t believe that a extension is the solution of the problem.
Resolution: INVALID.
of course it is not a Firefox' bug, but a developers' bug.
*** Bug 359414 has been marked as a duplicate of this bug. ***
Not sure this is same problem. I have the find toolbar. But my find function doesn't work anymore, not even if I use ctrl + f. the find text box just turns red immediately upon entering a search term. Oddly, the "highlight all" function still works. Does this warrant a new bug listing?
*** Bug 361906 has been marked as a duplicate of this bug. ***
*** Bug 363361 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 365840
Duplicate of this bug: 377503
Product: Firefox → Toolkit
Where can I enter feature request?
I want to request full FAYT back for the next versions.

and where can I find the real reason for this change?
I still can't believe that it was intentionally made. It simply makes no sense. Different features?! OMFG!
Duplicate of this bug: 1006047
You need to log in before you can comment on or make changes to this bug.