Add Commit Button below the top fields on show_bug.cgi

RESOLVED FIXED in Bugzilla 3.4

Status

()

P1
enhancement
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: rob.greer, Assigned: guy.pyrzak)

Tracking

unspecified
Bugzilla 3.4
Dependency tree / graph
Bug Flags:
approval +
approval3.2 -

Details

(Whiteboard: [wanted-bmo])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; InfoPath.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: All Bugzilla Versions - Browser Independent

Since many bug changes only relate to the initial Bugzilla form elements, to remove the need for scrolling, I propose adding a Commit button to the top fold of the bug report screen in addition to the Commit button found below the fold.

Reproducible: Always

Steps to Reproduce:
1. NA
Actual Results:  
N/A
Assignee: nobody → create-and-change
Component: General → Creating/Changing Bugs
Product: Firefox → Bugzilla
QA Contact: general → default-qa

Comment 1

12 years ago
would be nice to see "add ... to cc list" next to it which is where it belongs (IMO, plus not waste vertical space)

Comment 2

12 years ago
Sounds reasonable to me.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Summary: Add Commit Button to Top of Screen → Add Commit Button below the top fields on show_bug.cgi

Updated

12 years ago
Duplicate of this bug: 365117
(Assignee)

Comment 4

10 years ago
Created attachment 336282 [details] [diff] [review]
Commit Top Patch V1

attempt 1
Assignee: create-and-change → guy.pyrzak
Attachment #336282 - Flags: review?(mkanat)
Attachment #336282 - Flags: review?(LpSolit)
(Assignee)

Comment 5

10 years ago
Comment on attachment 336282 [details] [diff] [review]
Commit Top Patch V1

oops forgot the user.id if
Attachment #336282 - Flags: review?(mkanat)
Attachment #336282 - Flags: review?(LpSolit)
(Assignee)

Comment 6

10 years ago
Created attachment 336291 [details] [diff] [review]
Commit Top Patch V2
Attachment #336282 - Attachment is obsolete: true
Attachment #336291 - Flags: review?(mkanat)
Attachment #336291 - Flags: review?(LpSolit)
An alternative option to multiplying commit buttons would be to add a shortcut key. We used to have more of those, but we removed them because they clashed with menus, as Firefox used the same accelerator (Alt). I think this has now been changed, so we could have Alt-Shift-C as Commit using only HTML.

Gerv
Adding this to bmo-regressions for tracking, since this has been a common complaint among bmo users.  As a side-note, the current patch does not apply cleanly to the bmo/3.2 branch.
Blocks: 452731
I fixed this patch to apply to bmo (see revision 6138 on the bmo/3.2 bzr branch), but I'm not sure it's all there yet.  The most common changes made seem to be around status/resolution and CC list, and it still requires scrolling to get to the buttom from those actions.  I'm thinking it should probably be up towards the actual top of the form somewhere.  I did commit it to bmo as-is though, because it's still loads better than having to scroll down past the comment. :)

Comment 10

10 years ago
We really need an "In progress" status for bugs like this...

Comment 11

10 years ago
(In reply to comment #10)
> We really need an "In progress" status for bugs like this...

Why? I don't see why this would be useful.

Comment 12

10 years ago
Comment on attachment 336291 [details] [diff] [review]
Commit Top Patch V2

I'd rather just have it at the top of the page, kind of like you have it in PRACA.
Attachment #336291 - Flags: review?(mkanat)
Attachment #336291 - Flags: review?(LpSolit)
Attachment #336291 - Flags: review-

Updated

10 years ago
Priority: -- → P1
(Assignee)

Comment 13

10 years ago
Created attachment 358870 [details] [diff] [review]
V3 of patch
Attachment #336291 - Attachment is obsolete: true
Attachment #358870 - Flags: review?(mkanat)

Updated

10 years ago
Attachment #358870 - Flags: review?(mkanat) → review+

Comment 14

10 years ago
Comment on attachment 358870 [details] [diff] [review]
V3 of patch

Looks great.

We should also change the text to "Save Changes" like you guys did in PRACA. Maybe in another bug?

Updated

10 years ago
Flags: approval+
Target Milestone: --- → Bugzilla 3.4
bmo took this on 3.2, so it seems reasonable just to get this into 3.2 proper.
Flags: approval3.2?
Whiteboard: [wanted-bmo]

Comment 16

10 years ago
Comment on attachment 358870 [details] [diff] [review]
V3 of patch

>+          [% PROCESS commit_button id=""%]

Missing whitespace after "".


>+      [% PROCESS commit_button id="_top"%]

Same here.


Please add them on checkin.

Comment 17

10 years ago
No, this won't go into 3.2, it's an enhancement. It's also not the same thing that bmo has. It would, in fact, break one of bmo's customizations.
Status: NEW → ASSIGNED
Flags: approval3.2? → approval3.2-
(Assignee)

Comment 18

10 years ago
Checking in bugzilla/skins/standard/show_bug.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/show_bug.css,v  <--  show_bug.css
new revision: 1.11; previous revision: 1.10
done
Checking in bugzilla/template/en/default/bug/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/edit.html.tmpl,v  <--  edit.html.tmpl
new revision: 1.150; previous revision: 1.149
done
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Blocks: 477391
You need to log in before you can comment on or make changes to this bug.