If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"Failed to set Handler" error when no feed reader is selected

VERIFIED DUPLICATE of bug 344279

Status

()

Firefox
RSS Discovery and Preview
--
minor
VERIFIED DUPLICATE of bug 344279
11 years ago
8 years ago

People

(Reporter: Adam Guthrie, Unassigned)

Tracking

2.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

1. Create a new profile and go to http://slashdot.org/
2. Click on the RSS feed icon.
3. Look in the console.

I get this error:
*** Failed to set Handler: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: file:///home/aguthrie/downloads/bonecho-beta1-rc3/components/FeedWriter.js :: FW__initSelectedHandler :: line 254"  data: no]

It's trying to get the browser.feeds.handler preference, but that doesn't exist yet because we haven't set it. 

My guess would be that we set that pref. here: http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/feeds/content/options.js&rev=1.9#56  but that hasn't been called yet since we haven't actually opened the dialog.

Probably need to set a default for this pref. in firefox.js or something...
This isn't a bug, this is just diagnostic logging, which will be disabled by 344279

*** This bug has been marked as a duplicate of 344279 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Verified Duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.