If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

spelling checker considers word complete when apostrophe typed

RESOLVED WORKSFORME

Status

()

Core
Spelling checker
RESOLVED WORKSFORME
11 years ago
10 months ago

People

(Reporter: dbaron, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

The spelling checker does not mark words that are in the middle of being typed as misspelled.  However, this does not work correctly for words with an apostrophe in the middle.

Steps to reproduce:
 1. load this bug report
 2. click in the "Additional Comments" field
 3. type "aren't weren't shouldn't"

Actual results:
 3. After typing each of the three apostrophes, the current word being typed is underlined until the t is typed

Expected results:
 3. No underlining of misspelled words, since only incomplete words are misspelled.

Additional information:
Bug 237344 is very remotely related.
Assignee: brettw → mscott

Updated

10 years ago
Duplicate of this bug: 390103

Updated

10 years ago
Duplicate of this bug: 418935

Updated

10 years ago
Duplicate of this bug: 422982

Comment 4

10 years ago
Oddly, I never noticed this until the Firefox 3 beta, and it does not seem to affect Thunderbird 2, even though this bug was filed in 2006.  I'm seeing it all the time in Firefox 3, though.  I've added a bunch of "words" to my dictionary that aren't actually words because Firefox can no longer recognize contractions as single words.

Comment 5

10 years ago
Bug 422982 and comment 4 sound more severe than this bug as reported in comment 0, and could be a regression.

Comment 6

9 years ago
Adding to confirm that this bug occurs on the windows version as well.  I'm running Firefox 3, RC2.  Words like "can't" "won't" trigger a bad spelling before the apostrophe.  the description above describes the misspelling underline going away after the word is completed, however I have noticed that the underline remains even after completely typing these words and moving on.

Updated

9 years ago
Assignee: mscott → nobody

Comment 7

9 years ago
I think too that Bug 422982 is a more severe regression than this issue because there, the wrong underlining is not removed until the paragraph is closed by pressing "Enter".

A workaround is suggested there and maybe someone can test it.

Comment 8

9 years ago
BTW, on Debian and with their modified FF, this issue seems to be absent.

Updated

9 years ago
Duplicate of this bug: 457294
On Firefox 3.6.12 on OSX, I can't reproduce the issue anymore either. Seems to have been fixed along the way somewhere. Dbaron, can you confirm and close this bug?
WFM current nightly build
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.