Microsummaries use wrong charset encoding on non ascii pages

RESOLVED DUPLICATE of bug 345016

Status

RESOLVED DUPLICATE of bug 345016
13 years ago
3 years ago

People

(Reporter: p.franc, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
Testing a new microsummary for our Czech Mozilla page (in iso-8859-2) I found out that the resulting text is in wrong encoding. Sometimes the encoding is correct but mostly it is wrong (even if I use the iso-8859-2 generator). 

Sometimes if you play with both UTF-8 / iso-8859-2 generators switching between them and reloading the title from the context menu (or maybe it is just enough to load the page and reload the title), the encoding gets fixed. 

http://artax.karlin.mff.cuni.cz/~pfra7136/czilla/microsummaries-bug.png shows two examples of the bug - see the black squares or ? in the microsummary title.

Comment 1

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060710 Firefox/2.0b1

This works for me on Linux. (I've also been doing some additional testing of microsummaries and didn't see this issue with character encoding.) Windows only?
The server is only sending "Content-Type: text/html" in the HTTP headers, and the page is relying on the <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-2"/> in the content to switch to the correct charset. So, this is a dupe.


*** This bug has been marked as a duplicate of 345016 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.