The default bug view has changed. See this FAQ.

Mediaplayer plug-in doesn't start when using a mms data URI

VERIFIED DUPLICATE of bug 346167

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 346167
11 years ago
11 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
While Firefox 1.5.0.x doesn't show the following behavior, it is visible with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060714 Minefield/3.0a1 and the current Fx 2.0b1 under WinXP.

When loading the attached testcase with Firefox 1.5 the Mediaplayer is opened and the video played. Newer versions of Firefox show a odd behavior. After the attachment is loaded the mediaplayer plug-in is not loaded. The doc view is still empty. If you try to save the page and hit ok inside the save dialog, it will be saved and the mediaplayer is opened as an external application.

The desired behavior for Fx 2.0 and trunk builds should be the same like it's implemented in Fx 1.5.
(Reporter)

Comment 1

11 years ago
Created attachment 229399 [details]
Mediaplayer will only be started as an external application when saving the page
(Reporter)

Comment 2

11 years ago
This problem seems to only occur for mms data uri. If I change the URI from "mms://trog.ni.com/ni/webevents/lv/softwarearchitectures_fast.wmv" to a local file the mediaplayer is opened when the page is loaded.

I haven't found any other mms data URI examples. Anyone who knows a URL we could check?
Summary: Mediaplayer plug-in doesn't start when opening a page but when saving it → Mediaplayer plug-in doesn't start when using a mms data URI

Comment 3

11 years ago

*** This bug has been marked as a duplicate of 346167 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

11 years ago
Sadly, this is an older bug but seems to be missed by the bugzilla search.

v.
Status: RESOLVED → VERIFIED
Yes, this is a sad situation.
This bug would probably have been noticed if it was filed in Core->Plugins instead of Firefox->General.
Also, if you could find a regression window, then you could block the bug that caused this bug and cc the person who wrote the patch.
These aren't really things that are your responsibility, I know, but it makes it easier to keep track of things.
You need to log in before you can comment on or make changes to this bug.