Last Comment Bug 346167 - Windows MediaPlayer plugin stopped working on specific website with FF 1.5.0.5 (mms)
: Windows MediaPlayer plugin stopped working on specific website with FF 1.5.0....
Status: VERIFIED FIXED
: regression, verified1.8.0.6, verified1.8.1
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Other Branch
: All All
: -- critical (vote)
: ---
Assigned To: Jonas Sicking (:sicking) PTO Until July 5th
:
Mentors:
http://news.orf.at/video/iptvpopup.ht...
: 344859 346057 346060 346286 346395 346488 346566 346720 348525 (view as bug list)
Depends on:
Blocks: 181860
  Show dependency treegraph
 
Reported: 2006-07-27 13:26 PDT by Frank Wein [:mcsmurf]
Modified: 2006-08-13 07:29 PDT (History)
30 users (show)
dbaron: blocking1.8.1+
dveditz: blocking1.8.0.6+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch to fix (1.21 KB, patch)
2006-07-27 15:19 PDT, Jonas Sicking (:sicking) PTO Until July 5th
bzbarsky: review+
bzbarsky: superreview+
dveditz: approval1.8.0.6+
mtschrep: approval1.8.1+
Details | Diff | Review
Patch (1.23 KB, patch)
2006-07-30 17:04 PDT, JP
no flags Details | Diff | Review

Description Frank Wein [:mcsmurf] 2006-07-27 13:26:49 PDT
To reproduce:
1. Fetch Firefox 1.5.0.5
2. Go to http://news.orf.at/video/iptvpopup.html?lebanon_khiam_a.wmv

Actual results:
No Windows MediaPlayer plugin can be observed, no video is played

Expected results:
You should see a video playing there with the Windows MediaPlayer plugin

This worked fine in Firefox 1.5.0.4
Comment 2 Daniel Veditz [:dveditz] 2006-07-27 14:16:56 PDT
Presumably broken on 1.8 branch too, though we should test that
Comment 3 Jonas Sicking (:sicking) PTO Until July 5th 2006-07-27 14:57:54 PDT
This is a regression from bug 181860. The page fails because it uses the 'mms' protocol, which we consider external and block.
Comment 4 Jonas Sicking (:sicking) PTO Until July 5th 2006-07-27 15:19:49 PDT
Created attachment 231005 [details] [diff] [review]
Patch to fix

The problem here is that we don't do the loading, so a larger array of protocols are ok and don't neccesarily cause launching of external apps. The fix is very simple in that it simply allows object-urls to point to anything.

The big question here is of course, should we do a quick 1.5.0.6 release to fix this? The regression will cause any external protocols to be blocked even for plugins. This includes things like 'mms' for WMP and 'rm' for real. But I don't really know how common they are. But I suspect they are common enough that we need to fix this ASAP
Comment 5 Boris Zbarsky [:bz] (Out June 25-July 6) 2006-07-27 16:29:22 PDT
Comment on attachment 231005 [details] [diff] [review]
Patch to fix

Yeah, this will basically break all WMP objects... :(  We should probably at least consider doing a 1.8.0.6 to fix this; please mail the 1.8.0 branch drivers about it?

Please add a comment explaining why we let through TYPE_OBJECT (and I agree with the reasoning, btw -- we only AsyncOpen channels for plug-ins if we have a protocol handler for them), and looks good.
Comment 6 Adam Guthrie 2006-07-27 16:33:32 PDT
*** Bug 346057 has been marked as a duplicate of this bug. ***
Comment 7 Adam Guthrie 2006-07-27 16:36:07 PDT
*** Bug 344859 has been marked as a duplicate of this bug. ***
Comment 8 Jonas Sicking (:sicking) PTO Until July 5th 2006-07-27 16:39:52 PDT
For what it's worth, this patch was shipped in FF 2.0 Beta 1 and no-one has filed a bug on it yet.
Comment 9 :Gavin Sharp [email: gavin@gavinsharp.com] 2006-07-27 16:43:36 PDT
(In reply to comment #8)
> For what it's worth, this patch was shipped in FF 2.0 Beta 1 and no-one has
> filed a bug on it yet.

Bug 344859 was filed against b1/trunk.
Comment 10 Jonas Sicking (:sicking) PTO Until July 5th 2006-07-27 17:17:25 PDT
Fixed on trunk
Comment 11 Henrik Skupin (:whimboo) 2006-07-28 05:26:30 PDT
*** Bug 346060 has been marked as a duplicate of this bug. ***
Comment 12 Frank Wein [:mcsmurf] 2006-07-28 05:39:24 PDT
In case you cannot reproduce the bug anymore with the testcase from the URL, try Attachment 229399 [details] for an alternative testcase.
Comment 13 Rob Marshall [tH] 2006-07-28 07:00:19 PDT
*** Bug 346286 has been marked as a duplicate of this bug. ***
Comment 14 Daniel Veditz [:dveditz] 2006-07-28 12:01:36 PDT
Comment on attachment 231005 [details] [diff] [review]
Patch to fix

approved for 1.8.0 branch, a=dveditz
Comment 15 ERIC WANG 2006-07-28 12:48:42 PDT
here is a Resolution:

If you use mms://server/path/mediafile in FF1.5.0.5 in <OBJECT>, it will not work,
you should change to use http://server/path/mediafile.asx, this is work.

How to convert mms to http:

here is a example using PHP code:

file: test.asx.php

<?
Header("Content-Type: video/x-ms-asf");
$url = $_SERVER["QUERY_STRING"];
?>
<ASX Version="3.0">
<ENTRY>
<REF href="mms://mmsserver/<?=$url?>"/>
</ASX>
Comment 16 Jonas Sicking (:sicking) PTO Until July 5th 2006-07-28 13:34:12 PDT
For testing, the big thing to test here is anything that concerns external protocols.

This includes plugins that use custom streaming protocols like 'mms' or 'rm'. It also includes things like 'mailto' links that are supposed to open apps when clicked. And any other context where external protocols can be used that you can think of.

The patch is supposed to block external protocols from image, script, stylesheet and xbl load, but testing all those areas are hard and is going to suck up a lot of time. So I think it's more important to focus on testing external protocols whereever we can think of them.
Comment 17 Keith Walters 2006-07-28 13:59:01 PDT
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060728 BonEcho/2.0b1 - Build ID: 2006072803

I have tried this link http://www.milaadesign.com/wizardy.html in normal mode and safe mode and nothing happens.  Does not ask for any plug-in just will not load. I open it in IE and it works fine. Not sure if this branch Issue is effected by this bug or not just giving another web link to look at.
Comment 18 chris hofmann 2006-07-28 16:23:40 PDT
reports are that http://mlb.com streaming video is broken in 1.5.0.5.  that might be another good test case for builds with the patch.
Comment 19 Tracy Walker [:tracy] 2006-07-28 20:43:14 PDT
(In reply to comment #17)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060728
> BonEcho/2.0b1 - Build ID: 2006072803
> 
> I have tried this link http://www.milaadesign.com/wizardy.html in normal mode
> and safe mode and nothing happens.  Does not ask for any plug-in just will not
> load. I open it in IE and it works fine. Not sure if this branch Issue is
> effected by this bug or not just giving another web link to look at.
> 
that site WFM with the stated build and it works in 1.5.0.5.
Comment 20 Ryan Flint [:rflint] (ping via IRC for reviews) 2006-07-29 00:30:23 PDT
*** Bug 346395 has been marked as a duplicate of this bug. ***
Comment 21 Jesse Ruderman 2006-07-29 21:12:27 PDT
*** Bug 346488 has been marked as a duplicate of this bug. ***
Comment 22 Frank Wein [:mcsmurf] 2006-07-30 02:05:15 PDT
Patch has been checked in on MOZILLA_1_8_0_BRANCH at 2006-07-28 12:20.
Comment 23 Mike Schroepfer 2006-07-30 10:01:45 PDT
Comment on attachment 231005 [details] [diff] [review]
Patch to fix

approved by schrep for drivers
Comment 24 Rob Marshall [tH] 2006-07-30 10:38:42 PDT
*** Bug 346566 has been marked as a duplicate of this bug. ***
Comment 25 JP 2006-07-30 17:04:15 PDT
Created attachment 231346 [details] [diff] [review]
Patch
Comment 26 JP 2006-07-30 17:05:22 PDT
Comment on attachment 231346 [details] [diff] [review]
Patch

dude how do i get it to work
Comment 27 JP 2006-07-30 17:06:51 PDT
ok so i see the string can u tell me what to do with it
Comment 28 Paul Bergsagel 2006-07-31 19:41:44 PDT
Is this a MacOS bug as well. I cannot view anything at the test page above after the logo at the top of the page.

MacOS 10.3.9 and SeaMonkey 1.0.3
Comment 29 Ria Klaassen (not reading all bugmail) 2006-08-01 12:39:51 PDT
*** Bug 346720 has been marked as a duplicate of this bug. ***
Comment 30 Henrik Skupin (:whimboo) 2006-08-02 00:28:20 PDT
WFM now with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060801 Minefield/3.0a1

v.
Comment 31 Jason Reep 2006-08-10 11:25:42 PDT
Still broken for me.  ASX files which call either MMS or HTTP streams result in a blank browser window with no external or embedded player launched.  If a WMV file is directly linked I get the "This protocol requires an external application to be launched.  Do you want to launch this app.."  This will launch whichever the default player is specified as the default player for that file extension and successfully play video.  However, if it's an ASX file launching the video...Nothing.

See this thread http://forums.mozillazine.org/viewtopic.php?t=441848 for some more examples.  The NoScript extension and ActiveX plugin are suspected as potential issues involved but with or without those items the behavior is still inconsistent and broken.
Comment 32 Jason Reep 2006-08-10 11:27:44 PDT
sorry, here's my build ID
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060809 Minefield/3.0a1 (bangbang023) ID:0000000000 [cairo]
Comment 33 Jonas Sicking (:sicking) PTO Until July 5th 2006-08-10 11:55:54 PDT
Jason: It sounds like you're running into a different bug. Did the same pages work in 1.5.0.4? If not then please file a new bug.
Comment 34 Rob Marshall [tH] 2006-08-13 07:29:00 PDT
*** Bug 348525 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.