Toolbar search box does not resize correctly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
3 years ago

People

(Reporter: mozbugs, Unassigned)

Tracking

({regression})

2.0 Branch
regression
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060714 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b1) Gecko/20060714 BonEcho/2.0b1

If you drag the search box down to the right of the bookmarks toolbar and add enough bookmarks to display the chevron, the editable part of the box shrinks to zero obscuring your search terms.

Reproducible: Always

Steps to Reproduce:
1.Customize so search is to the right on the bookmarks toolbar
2.Add bookmarks until the chevron appears
3.

Actual Results:  
The search box is too small to use


Notice the space between the rightmost visible bookmark and the search box.
If you now remove some bookmarks the search box does not expand.
Additionally, if you initially drag the box to the left on the bookmarks toolbar the chevron overlays part of the bookmark title.
Yeah, I see the same. After a restart however it grows a bit. Not sure why it behaves that way. A simple 
.searchbar-textbox {min-width: 15em !important;}
seems to cure it here. But it remains a mystery why "width: 15em" is only valid for the navigation toolbar and not for the bookmarks toolbar.

I see a real regression in it: between 1.9a1_2006051110 and 1.9a1_2006051116.
Keywords: regression
Yes, it was a regression from making the search bar flex, bug 258679. We could probably set a min-width.
(Reporter)

Comment 4

12 years ago
I forgot to mention, the bug is also visible on the navigation toolbar ;)
- I drag the Go & address box up to the menu bar, & then drag the bookmarks toolbar to the right of the search box. If I then untick view->toolbars-> bookmarks toolbar it gives me more space on my small screen.
*** Bug 351668 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

12 years ago
Created attachment 245266 [details]
screenshot of effects
*** Bug 360912 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
My bug is the one that just got marked dupe -- I'd like to note that I experience this when the search bar is on the left.

Updated

11 years ago
Flags: blocking-firefox3?

Updated

11 years ago
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
May be WFM with the splitter/resizer changes, but either way, not blocking.

Comment 10

9 years ago
I have experienced this bug in Windows as well for quite some time.  This also happens when Firefox is first started.
Blocks: 258679
OS: Linux → All
Hardware: x86 → All
Version: unspecified → 2.0 Branch

Comment 11

9 years ago
Oops sorry, I should have mentioned my version: 3.5.1

Comment 12

9 years ago
I'm hitting this too after moving from 3.0.x over to Firefox 3.5 (3.5.2) on Linux and Windows. Searchbar is to the right in my bookmark toolbar. Simply hitting Customize and then Finish fixes the width of the searchbar until next restart.
The search bar currently seems to retain a wide enough size so that it's still usable, it could probably grow by some ems, but that's not critical.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.