Search bar on toolbar no longer resizes with browser width

RESOLVED FIXED

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
13 years ago
8 years ago

People

(Reporter: Thomas Rutter, Assigned: Joe Hughes)

Tracking

({fixed1.8.1, regression})

unspecified
fixed1.8.1, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.8b5 -
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040909 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040909 Firefox/0.10

The search field on the toolbar (google) no longer resizes to a reasonable size
when the browser window changes, and it is not possible to modify the size in
userChrome.css.

This is a regression in today's build (20040909).

Previously the search field resized nicely.

Reproducible: Always
Steps to Reproduce:
1. Open Firefox
Actual Results:  
Search field very small, only fits two words.

Expected Results:  
Search field around 25% of browser width.

It's not possible to modify this with the following setting in userChrome either:

#search-container {
-moz-box-flex: 400 !important;
}

Comment 1

13 years ago
see bug 258343 comment 3 and comment 8, though I haven't seen a post on mz yet.
Assignee: bugs → p_ch
I did some digging and found this solution, not sure if its necessarily the best
way to do it, but it seems to work for most people.

/* Make the Search box flex wider */
#search-container {
   -moz-box-flex: 200 !important;
}

#searchbar {
   -moz-box-flex: 200 !important;
}

Comment 3

13 years ago
*** Bug 258730 has been marked as a duplicate of this bug. ***
This could also probably be fixed (i.e. reverted to the previous behaviour) by
adding a flex="1" attribute onto the searchbar element in the chrome. I've only
tested it using the dom inspector to add the attribute and am not really up to
the task of making a patch for this, perhaps someone else could oblige?
Likely caused by the following checkin:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=AviaryBranchTinderbox&branch=&branchtype=match&dir=&file=browser.xul&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-09-07+07%3A40%3A00&maxdate=2004-09-07+08%3A00%3A00&cvsroot=%2Fcvsroot

Is this still apparent on the latest nightlies?
Status: UNCONFIRMED → NEW
Ever confirmed: true
This problem is still apparent in 1.0PR.

Comment 7

13 years ago
isn't this bug invalid?
the default themes use a constant size for the searchbar.
I guess the themes should be updated, by looking at searchbar.css and by
removing searchbar references in browser.css

Comment 8

13 years ago
I wouldn't think that it is invalid because we have allowed resizing the search
bar since at least Phoenix 0.5.  Also, in many cases, the search bar is too
small to display long queries.  Also, for people who have moved the location bar
to another toolbar, expanding the search bar is a good use of the added space on
the toolbar.

Flexibility was the whole point of being able to customize the toolbars in the
first place.  We shouldn't make it less flexible.

Also, the location bar expands to occupy whatever free space is available on its
toolbar, so the search bar should at least have the possibility to expand, even
if only via userChrome.css.
Flags: blocking-aviary1.0?
Keywords: regression

Updated

13 years ago
Flags: blocking-aviary1.0?

Comment 9

13 years ago
*** Bug 261483 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
Created attachment 162579 [details]
The circled region and the dot show where a resize control should be located

I created the image to emphasize what I think 
is the problem here.  There's no "resize control"
present, as is in Safari.  Without it, entering
long search strings is error-prone and tedious.

Comment 11

13 years ago
IMHO, this bug is a DUPLICATE of bug 205011.

Comment 12

13 years ago
Since we already have the adjusted information for the userChrome.css file to
allow resizing of the search bar are people wanting the ability to resize on the
fly built in.

http://dragtotab.mozdev.org/resizesearchbox/

Like what that extension provides. In which case this bug should be marked as an
enhancement bug.
(Reporter)

Comment 13

13 years ago
(In reply to comment #12)
> Since we already have the adjusted information for the userChrome.css file to
> allow resizing of the search bar are people wanting the ability to resize on the
> fly built in.

> In which case this bug should be marked as an
> enhancement bug.

The bug's intention is to point out that a previous feature no longer works. 
The bar used to resize to a percentage of the browser width; now it doesn't do
it anymore (without editing userChrome.css).

> IMHO, this bug is a DUPLICATE of bug 205011.

It isn't, though that bug is still worthwhile it isn't connected to this one. 
This one concerns whether the width of the search bar will be determined as a
percentage of the browser width and therefore resize accoding to the size of the
browser window, or if it is a fixed size and only the location bar should
resize.  For a short time during aviary development, it was the former and I
think it was better that way.

Here's what you need to add to userChrome.css to reproduce that behaviour now:

#search-container {
   -moz-box-flex: 20% !important;
}

#searchbar {
   -moz-box-flex: 20% !important;
}
(Reporter)

Updated

13 years ago
Summary: Search bar on toolbar no longer resizes → Search bar on toolbar no longer resizes with browser width

Updated

12 years ago
Flags: blocking-aviary1.5?

Updated

12 years ago
Flags: blocking1.8b4?

Updated

12 years ago
Flags: blocking1.8b4?
Flags: blocking1.8b4-
Flags: blocking-aviary1.5?
Flags: blocking-aviary1.5-

Updated

12 years ago
QA Contact: bugzilla → toolbars
Assignee: p_ch → nobody
OS: Windows XP → All
Hardware: PC → All
*** Bug 329662 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

12 years ago
Blocks: 335435
(Assignee)

Comment 15

12 years ago
Comment on attachment 162579 [details]
The circled region and the dot show where a resize control should be located

Obsoleting irrelevant screenshot
Attachment #162579 - Attachment is obsolete: true
(Assignee)

Comment 16

12 years ago
Created attachment 221312 [details] [diff] [review]
Put proportional flex back into searchbar
Assignee: nobody → joe
Status: NEW → ASSIGNED
Attachment #221312 - Flags: review?(gavin.sharp)
Comment on attachment 221312 [details] [diff] [review]
Put proportional flex back into searchbar

r=gavin
Attachment #221312 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

12 years ago
Attachment #221312 - Flags: superreview?(bugs)
Comment on attachment 221312 [details] [diff] [review]
Put proportional flex back into searchbar

sr=ben@mozilla.org
Attachment #221312 - Flags: superreview?(bugs) → superreview+
Comment on attachment 221312 [details] [diff] [review]
Put proportional flex back into searchbar

woo, ship it!
Attachment #221312 - Flags: approval-branch-1.8.1+
(Assignee)

Comment 20

12 years ago
Landed on branch, waiting for trunk to reopen.
Keywords: fixed1.8.1

Comment 21

12 years ago
screen shot : http://img302.imageshack.us/img302/8486/searchbox11qr.jpg

invisible locationbar is dangerous, if it is a phishing/scam site, I think.
what do you think?
(Assignee)

Comment 22

12 years ago
(In reply to comment #21)
> screen shot : http://img302.imageshack.us/img302/8486/searchbox11qr.jpg
> 
> invisible locationbar is dangerous, if it is a phishing/scam site, I think.
> what do you think?

Thanks for pointing that out--though since the window-shrinking behavior is basically the same as Firefox 1.5's, I don't think it's entirely relevant to this discussion.  If you're still concerned, please open a new bug on the subject.
(Assignee)

Comment 23

12 years ago
Marking this resolved, since it's now landed on branch & trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 24

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060512 Minefield/3.0a1 ID:2006051208 [cairo]

http://img142.imageshack.us/img142/1149/ff20060512019cs.jpg
above:Minefield
below:Bone Echo
(1280*960 monitor)

search box on Minefield is too wide/long.
Please shorten. or make it same as Bon Echo.
(Assignee)

Comment 25

12 years ago
(In reply to comment #24)
> search box on Minefield is too wide/long.
> Please shorten. or make it same as Bon Echo.

Pal, you'll be able to set it to whatever size you want once 205011 lands.
Depends on: 348779
No longer depends on: 348779
Depends on: 344941
You need to log in before you can comment on or make changes to this bug.