Text change events not fired in dynamically inserted Midas areas

RESOLVED DUPLICATE of bug 390414

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 390414
12 years ago
11 years ago

People

(Reporter: Aaron Leventhal, Assigned: Aaron Leventhal)

Tracking

(Blocks: 1 bug, {access})

Trunk
access
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Assignee)

Description

12 years ago
Events are not fired for text deletions or insertions in Midas areas such as:
http://www.dynarch.com/demos/htmlarea/examples/core.html

However, caret and selection move events appear to work okay.

It seems that WillDeleteText/DidInsertText etc. are not being called. In fact, the nsIEditActionListener appears to be registered for a different editor.
(Assignee)

Comment 1

12 years ago
Changing summary because the mozilla.org demo does work, although I had to tweak the caret movement code. Here's the working demo:
http://www.mozilla.org/editor/midasdemo/
Summary: Text change events not fired in Midas areas → Text change events not fired in some Midas areas
(Assignee)

Comment 2

12 years ago
In the non-working example, the iframe is inserted into the document.
Blocks: 342901
No longer blocks: 333492
Summary: Text change events not fired in some Midas areas → Text change events not fired in dynamically inserted Midas areas
(Assignee)

Updated

12 years ago
Blocks: 368895
No longer blocks: 342901
(Assignee)

Comment 3

11 years ago
The work was done in a variety of bugs, including bug 390414.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 390414
You need to log in before you can comment on or make changes to this bug.