Closed Bug 345341 Opened 15 years ago Closed 14 years ago

[ad-blocking] Ad blocker fails to block overlay advertisement

Categories

(Camino Graveyard :: Annoyance Blocking, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Camino1.5

People

(Reporter: fowler.amsterdam, Assigned: alqahira)

References

()

Details

(Keywords: fixed1.8.1)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2

With ad blocking on, inline ads are blocked, but on first visit to this page in Camino an overlay ad appears at top of page (for Nokia). Interestingly, this ad does not appear in Firefox or Safari...A special "Camino only" ad to prove they can thwart the blocker??

Reproducible: Couldn't Reproduce

Actual Results:  
Non-reproducable results could be from ad serving software only serving on first visit...I believe this is common with overlay ads
This is fixed by the rules we have in bug 342956 (which should land in nightlies by the end of the month, I hope,).
Status: UNCONFIRMED → ASSIGNED
Depends on: 342956
Ever confirmed: true
Summary: Ad blocker fails to block overlay advertisment → [ad-blocking] Ad blocker fails to block overlay advertisement
Target Milestone: --- → Camino1.1
Component: General → Annoyance Blocking
QA Contact: general → annoyance.blocking
Fixed by patch in bug 342956.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
(In reply to comment #2)
> Fixed by patch in bug 342956.
> 

I'm running 2006072802, and I just saw this Nokia ad on http://www.wired.com/news/technology/0,71521-1.html?tw=wn_story_page_next1

If I understand the above correctly, if I was running an August build, this wouldn't have happened? (i.e. the flash ad, published from klipmart.com via the bleow JavaScript, I think, would've been blocked?).

===
	</script><script language="JavaScript1.1" src="http://scripts.lycos.com/catman/init.js"> </script><script language="JavaScript">
	var catman = new AdManager();
	catman.setForcedParam("page", cm_page);
	var strProdSetName = catman.chooseProductSet();
	catman.renderHeader();
===
Assignee: nobody → alqahira
You need to log in before you can comment on or make changes to this bug.