Closed Bug 345628 Opened 14 years ago Closed 12 years ago

Download Actions List Empty / Corrupted mimeTypes.rdf file

Categories

(Toolkit :: Downloads API, defect, major)

x86
Windows 2000
defect
Not set
major

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: gustep12, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

A corrupted mimeTypes.rdf file will make the Download Actions list appear empty.

Reproducible: Always

Steps to Reproduce:
1. Exit Firefox. Place the attached mimeTypes.rdf file into the following folder:
2. C:\Documents and Settings\Administrator\Application Data\Mozilla\Firefox\Profiles\ahkfr1d9.Default User
3. Restart firefox

Actual Results:  
Download Actions list is empty

Expected Results:  
Download Actions list should have several entries
This is the corrupt mimeTypes.rdf file
324111

*** This bug has been marked as a duplicate of 324111 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
This is not a duplicate of bug 324111. Bug 324111 is for a corrupted extensions.rdf and the patch for that just works around the problem by removing the extensions.rdf since it will be automatically regenerated. The download mgr. has not been patched to do this and I don't know if doing so would be the correct solution.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Also, the attachment is valid rdf and bug 324111 fixes corrupt/invalid rdf.
O.k., thanks. Can someone confirm this bug with the attached file? Restoring the working condition afterwards is easy, just make a backup of your working mimeTypes.rdf file first.
corrupted mimeTypes.rdf after modification of an action
This problem is NOT unique to Windows 2000. E.g. it applies to Windows XP Home Edition. 

Is this bug related to the fact that the checkbox for
"Do this automatically for files like this from now on"
has no effect?
It seems the problem occurs more easily with certain category of players you choose for DL action i.e. ZoomPlayer ( http://www.inmatrix.com/ ).

The program name is not correctly read, and this seems to destroy mimeTypes.rdf (visible after Fx restart).

Cannot confirm Fx 1.5.0.7pre has exactly the same behaviour as some Fx1.5.0.6 versions I previously used.
Confirmed on 2.6.23.1-49.fc8 - i386 - Firefox 2.0.0.9-1 rpm binary.
Resolving old UNCONFIRMED Download Manager bugs as INCOMPLETE.  If you still see this issue, please reopen.

To mark all these bug changes as read, filter on ONOMATOPOEIA.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago12 years ago
Resolution: --- → INCOMPLETE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.