Last Comment Bug 345826 - Ability to save column list in saved searches
: Ability to save column list in saved searches
Status: RESOLVED FIXED
:
Product: Bugzilla
Classification: Server Software
Component: Query/Bug List (show other bugs)
: 2.22
: All All
: P2 enhancement (vote)
: Bugzilla 3.2
Assigned To: Ronaldo Maia
: default-qa
Mentors:
: 403573 (view as bug list)
Depends on:
Blocks: 443479
  Show dependency treegraph
 
Reported: 2006-07-25 02:01 PDT by Enrico Weigelt
Modified: 2008-08-07 18:18 PDT (History)
6 users (show)
LpSolit: approval+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (3.66 KB, patch)
2007-03-06 19:09 PST, Max Kanat-Alexander
LpSolit: review+
Details | Diff | Review

Description Enrico Weigelt 2006-07-25 02:01:58 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060719
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.13) Gecko/20060719


View of stored seaches should be customizable, so can ie. define Fields to be displayed there too.


Reproducible: Always
Comment 1 Max Kanat-Alexander 2006-07-26 00:09:44 PDT
Could you describe in a little more detail what you'd like?
Comment 2 Enrico Weigelt 2006-07-26 03:19:04 PDT
I'd like to be able to store also the fields to show, sort order, etc. with the search. For example if I search for bugs in some certain product, I obviously don't need the product name in the output.
Comment 3 Max Kanat-Alexander 2006-07-26 14:24:01 PDT
So Saved Searches don't currently save the columnlist parameter?
Comment 4 Enrico Weigelt 2006-07-27 16:19:52 PDT
No, no that I no, do they ?
Comment 5 hacksaw 2006-12-07 06:50:33 PST
I am running into this, and it some kind of bug, maybe a design bug.

If I save the URL from a previous buglist, with columnlist set, bugzilla sucks it in, and ignores it. The new url that shows up has the columnlist changed.

This is on Bugzilla 2.22.
Comment 6 Max Kanat-Alexander 2007-03-06 19:09:58 PST
Created attachment 257617 [details] [diff] [review]
v1

Hey LpSolit--this is romaia's patch--you've actually already reviewed it once. :-)

Do you think it needs any changes in order to go upstream? I like it pretty well.
Comment 7 Max Kanat-Alexander 2007-03-06 19:13:09 PST
Comment on attachment 257617 [details] [diff] [review]
v1

Should maybe some of the colchange.cgi parts be less hackish? That is, are there some security things that could be moved into Search::Saved?
Comment 8 Frédéric Buclin 2007-03-07 09:51:28 PST
Comment on attachment 257617 [details] [diff] [review]
v1

>=== modified file 'colchange.cgi'

>+    if ($cgi->param('save_columns_for_search') &&
>+        defined $search && $search->user->id == Bugzilla->user->id) {

Nit: use Bugzilla's style here, i.e.:

  if ($long_line_1
      && $long_line_2)
  {

I didn't complain on b.e.c because this was a very minor thing. ;)



>=== modified file 'template/en/default/list/change-columns.html.tmpl'

>+  [% IF saved_search %]
>+  <p>

Nit: please fix the indentation.


>+    <input type="checkbox" id="save_columns_for_search" checked="checked" 

Just one comment: note that the checkbox is crossed by default, which is a different behavior compared to what we have currently. But I think that's fine and is probably the right default (especially because this will only affects existing saved searches).

All my other comments have already been addressed in this patch, so r=LpSolit.


Note to the one doing the checkin: the author of the patch is romaia!
Comment 9 Frédéric Buclin 2007-03-07 09:52:28 PST
Reassigning to the original patch's author -> romaia.
Comment 10 Max Kanat-Alexander 2007-03-07 12:38:19 PST
Thanks to Adobe for sponsoring this work, by the way.

Checking in colchange.cgi;
/cvsroot/mozilla/webtools/bugzilla/colchange.cgi,v  <--  colchange.cgi
new revision: 1.59; previous revision: 1.58
done
Checking in template/en/default/list/change-columns.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/change-columns.html.tmpl,v  <--  change-columns.html.tmpl
new revision: 1.14; previous revision: 1.13
done
Comment 11 Frédéric Buclin 2007-08-20 14:47:23 PDT
*** Bug 105110 has been marked as a duplicate of this bug. ***
Comment 12 Frédéric Buclin 2007-11-12 22:12:05 PST
*** Bug 403573 has been marked as a duplicate of this bug. ***
Comment 13 Max Kanat-Alexander 2008-07-01 00:07:33 PDT
Added to the release notes for Bugzilla 3.2 in a patch on bug 432331.

Note You need to log in before you can comment on or make changes to this bug.