Closed Bug 345946 Opened 13 years ago Closed 13 years ago

firefox reports invalid message when it can't find profile directory

Categories

(Toolkit :: Startup and Profile System, defect)

1.8 Branch
x86
Windows XP
defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 278860

People

(Reporter: alex73mail, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; be-BY; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; be-BY; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

  I moved profile directory on the flash disk(for share firefox data between work and home computers). When I run firefox WITH flash disk, it works perfect. When I run firefox WITHOUT flash disk(i.e. profile directory can't be found), firefox reports : "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system.".
  It happen in firefox 1.5.0.4 and Firefox 2 beta1


Reproducible: Always

Steps to Reproduce:
1. Remove profile directory(but leave it in profile.ini), or change Path in the profile.ini into non-exists directory
2. Run firefox




Expected Results:  
Seems to firefox should report other message.
Version: unspecified → 2.0 Branch
This is a dup.
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.