Marlett font in bold TDs

RESOLVED DUPLICATE of bug 342143

Status

()

RESOLVED DUPLICATE of bug 342143
12 years ago
12 years ago

People

(Reporter: simaskonfa, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; lt; rv:1.9a1) Gecko/20060725 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; lt; rv:1.9a1) Gecko/20060725 Minefield/3.0a1

when a TD style primarily specifies a font-face that cannot be found or matched among user's font collection, and a font in that cell is drawn bold (string), a Marlett font is shown in that place (thus nothing can be read). 

Reproducible: Always

Steps to Reproduce:
1. Open any text editor
2. Enter the following text:
<html>
   <body>
      <table>
         <tr>
            <th style="font-family:blahblah;Arial">
               <b>SEEMS GOOD</b>
               Seems Good
            </th>
         </tr><tr>
            <td style="font-family:blahblah;Arial">
               <b>seems bad</b>
               Seems Good
            </td>
         </tr>
      </table>
   </body>
</html> 
3. Save it as .htm and launch it in Minefield
Actual Results:  
the page is viewed as:
SEEMS GOOD  Seems Good
seems bad Seems Good

where “seems bad" is written unreadably (in Marlett font – only quirky windows symbols)

Expected Results:  
the page should have shown instead:
SEEMS GOOD  Seems Good
seems bad Seems Good

This problem seemed to hang around for quite a while, and I had seen it fixed only in ~one nightly (~2 months ago). Since then, this problem has reappeared and pertains in each nightly.

Comment 1

12 years ago
Probably dupe of Bug 342143

Comment 2

12 years ago
A discussion can be found here: http://forums.mozillazine.org/viewtopic.php?t=443635

For me it looks more like ignoring of replacement fonts if the first one is not found.

<html>
   <body>
      <table>
         <tr>
            <td style="font-family:'blahblah,Arial';">
               <b>SEEMS GOOD</b>
               Seems Good
            </td>
         </tr><tr>
            <td style="font-family:'blahblah,Courier';">
               <b>seems bad</b>
               Seems Good
            </td>
         </tr>
      </table>
   </body>
</html>

Normally i expect the first line rendered in Arial and the second in Courier but both lines are rendered in Arial which is my default font.

BTW: Does not work for me in 1.5.0.4 too.

This one works in 1.5.0.4 (text rendered in Courier) but not in Minefield (text rendered in Arial):

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<style type="text/css">
td { font-family:xxx,Courier,Arial,monospace; }
</style>
</head>
<body>
<table>
<tbody>
<tr><td><b>SEEMS GOOD</b> Seems Good </td></tr>
<tr> <td><b>seems bad</b>Seems Good </td> </tr>
</tbody>
</table>
</body>
</html>

Comment 3

12 years ago
(In reply to comment #2)
This is not valid CSS:
font-family:'blahblah,Arial';

A sample from the spec looks like this:
<BODY STYLE="font-family: 'My own font', fantasy">
The single quotes are only needed around font family names that have spaces within them.  And the single quotes only go around that family name, not all of the names.
http://www.w3.org/TR/CSS21/fonts.html#font-family-prop

Comment 4

12 years ago
Well actually it's valid but the font family name will be interpreted as blahblah,Arial which won't match any fonts.

Comment 5

12 years ago
Simonas, what is your windows language?
Version: unspecified → Trunk

Comment 7

12 years ago
I'm marking this as duplicate since the URL is the same as in bug 342143 and they describe the same bug.

*** This bug has been marked as a duplicate of 342143 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

12 years ago
(In reply to comment #5)
> Simonas, what is your windows language?
> 

Standarts and formats is English (US)
Location is Lithuania
Language for non-Unicode: Lithuania

Comment 9

12 years ago
(In reply to comment #8)
> (In reply to comment #5)
> > Simonas, what is your windows language?
> > 
> 
> Standarts and formats is English (US)
> Location is Lithuania
> Language for non-Unicode: Lithuania
> 

Try to change Location to US and Language for non-unicode to English (US)
I did it and I can see text as expected.
anyway, it's a duplicate of bug 342143.
You need to log in before you can comment on or make changes to this bug.