Cairo incorrectly substitutes fonts and then bolds them incorrectly if you are not using Window XP's default regional and language options

RESOLVED FIXED

Status

()

Core
Graphics
--
major
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Kenny Lee, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
Windows XP
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: cairo, URL)

Attachments

(1 attachment)

240 bytes, text/html
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060616 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060619 Minefield/3.0a1

My Regional and Language settings for my Window XP is customed but only one or two options were changed. I only changed the Language for non-UNICODE programs from default to Chinese (PRC). And I have all Supplemental language support installed (e.g East Asian languages). 

Reproducible: Always

Steps to Reproduce:
1. Use other language other than Window XP's default language.
2. After reboot, surf to http://www.squarefree.com/burningedge/
3. You will see this -> https://bugzilla.mozilla.org/attachment.cgi?id=225136

Actual Results:  
You can see weird symbols on http://www.squarefree.com/burningedge/ page.

Expected Results:  
You shouldn't see weird symbols on http://www.squarefree.com/burningedge/

Comment 1

12 years ago
There's some more information in bug 330715#c32-36
Whiteboard: cairo
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

12 years ago
I am using Polish Windows XP. When the language for non-unicode is set to English everything is ok, but when I set it to Polish fonts go weird.

Comment 3

12 years ago
OK -- i'll get some vmware setup going in the next few days so I can test this easier.

Comment 4

12 years ago
*** Bug 345671 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
Created attachment 230733 [details]
Testcase

The first line is unreadable.
Note: this happening only when the text is bold and it's font doesn't exist.
(Reporter)

Comment 6

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060725 Minefield/3.0a1

Just to note that the test case above only happens only if you are not using default regional and language options. 

Updated

12 years ago
Blocks: 345671

Updated

12 years ago
Keywords: regression, testcase

Comment 7

12 years ago
*** Bug 346503 has been marked as a duplicate of this bug. ***

Comment 8

12 years ago
*** Bug 345968 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
I do not know if it is the same problem but in W2K the replacment font is not displayed bold.
This works in 1.5.0.5 (text is Courier) but fails in Minefield (text is Arial but not bold):
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>
<title>Font replacement test</title>
<style type="text/css">
td { font-family:xxx,Courier,Arial,monospace; }
</style>
</head>
<body>
<table>
<tbody>
<tr><td>
<b>SEEMS GOOD</b> - Seems Good </td></tr>
<tr> <td><b>seems bad</b> - Seems Good </td> </tr>
<tr> <td>seems bad - Seems Good </td> </tr>
</tbody>
</table>
</body>
</html>

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060730 Minefield/3.0a1 ID:2006073004 [cairo]

Comment 10

12 years ago
(Moved from a duplicate #345968)

(In reply to comment #9)
> (In reply to comment #8)
> > (In reply to comment #5)
> > > Simonas, what is your windows language?
> > > 
> > 
> > Standarts and formats is English (US)
> > Location is Lithuania
> > Language for non-Unicode: Lithuania
> > 
> 
> Try to change Location to US and Language for non-unicode to English (US)
> I did it and I can see text as expected.

OK, bug vanished as soon as the 'non-Unicode' settings were changed to English (US). Other settings have no influence. I hope, this bug will get soon fixed, I'll keep voting, monitoring and CVSing around this frequently ;)

Updated

11 years ago
Depends on: 352174
*** Bug 356014 has been marked as a duplicate of this bug. ***

Comment 12

11 years ago
I never seen this bug before, but have it with build 20061031 and 20061101. Build 20061026 not show this bug for me. My current build still Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061026 SeaMonkey/1.5a 
My OS is Windows XP sp2.

Comment 13

11 years ago
*** Bug 359184 has been marked as a duplicate of this bug. ***

Comment 14

11 years ago
Fixed by the patch for bug 352174.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.