Last Comment Bug 346302 - Yet another RFC 2231 violation (0x2a is not escaped)
: Yet another RFC 2231 violation (0x2a is not escaped)
Status: VERIFIED FIXED
: fixed1.8.0.7, verified1.8.1
Product: MailNews Core
Classification: Components
Component: Composition (show other bugs)
: Trunk
: x86 Windows XP
-- normal (vote)
: ---
Assigned To: Masatoshi Kimura [:emk]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-07-28 09:01 PDT by Masatoshi Kimura [:emk]
Modified: 2008-07-31 04:30 PDT (History)
2 users (show)
mscott: blocking‑thunderbird2+
dveditz: blocking1.8.0.7-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch rv 1.0 (2.69 KB, patch)
2006-07-28 09:02 PDT, Masatoshi Kimura [:emk]
no flags Details | Diff | Splinter Review
Patch rv 1.1 (1.99 KB, patch)
2006-07-28 09:27 PDT, Masatoshi Kimura [:emk]
masayuki: review+
mscott: superreview+
mscott: approval‑thunderbird2+
dveditz: approval1.8.0.7+
Details | Diff | Splinter Review

Description User image Masatoshi Kimura [:emk] 2006-07-28 09:01:42 PDT
This bug is missed when fixing bug 338859.
0x2a should also be escaped. It will appear only if 7-bit a charset is used.
Patch is coming.
Comment 1 User image Masatoshi Kimura [:emk] 2006-07-28 09:02:40 PDT
Created attachment 231102 [details] [diff] [review]
Patch rv 1.0
Comment 2 User image Masatoshi Kimura [:emk] 2006-07-28 09:27:48 PDT
Created attachment 231105 [details] [diff] [review]
Patch rv 1.1

Oops, I forgot that ':' could be used in filename on non-Windows platforms.
I'm planning to extend nsEscape to support RFC 2231, but it would not acceptable on branch (because it causes API change).
So I'll escape everything in this patch.
Comment 3 User image Masatoshi Kimura [:emk] 2006-07-28 09:30:16 PDT
> ':' could be used in
'*' could be used in
Sorry for the typo.
Comment 4 User image Masayuki Nakano [:masayuki] 2006-07-28 09:34:52 PDT
This is a standard compliance problem. We should block next release.
Comment 5 User image Scott MacGregor 2006-08-01 23:01:49 PDT
Comment on attachment 231105 [details] [diff] [review]
Patch rv 1.1

I'll let Masayuki review this patch too.
Comment 6 User image Masayuki Nakano [:masayuki] 2006-08-02 00:25:35 PDT
Comment on attachment 231105 [details] [diff] [review]
Patch rv 1.1

I tested Tb to Tb and Tb to Becky2. I don't find the regression. r=masayuki.

Please wait to check-in. I'll do tonight, sorry.
# If somebody can do before me, please do it.
Comment 7 User image Masayuki Nakano [:masayuki] 2006-08-02 07:34:05 PDT
checked-in to trunk, thank you Kimura-san.
Comment 8 User image Scott MacGregor 2006-08-02 08:03:55 PDT
Comment on attachment 231105 [details] [diff] [review]
Patch rv 1.1

approving for thunderbird 2 so this can land on the 1.8.1 branch.
Comment 9 User image Masayuki Nakano [:masayuki] 2006-08-02 09:19:49 PDT
checked-in to 1.8 branch too, thanks.
Comment 10 User image Masayuki Nakano [:masayuki] 2006-08-03 07:37:36 PDT
-> v. on trunk.
Comment 11 User image Masatoshi Kimura [:emk] 2006-08-04 21:26:58 PDT
Comment on attachment 231105 [details] [diff] [review]
Patch rv 1.1

We should fix standard conformance problem as soon as possible.
Illegal messages may survive in the archive for a long time.
Moreover, gnus (prior to 2006-06-20) didin't tolerate our violation.
Comment 12 User image Masayuki Nakano [:masayuki] 2006-08-05 02:40:43 PDT
-> v. on 1.8.1branch
Comment 13 User image Daniel Veditz [:dveditz] 2006-08-10 12:13:14 PDT
Comment on attachment 231105 [details] [diff] [review]
Patch rv 1.1

approved for 1.8.0 branch, a=dveditz for drivers
Comment 14 User image Daniel Veditz [:dveditz] 2006-08-10 12:14:28 PDT
Not blocking 1.8.0.7, but we're happy taking the patch if you get it in.
Comment 15 User image Masayuki Nakano [:masayuki] 2006-08-10 12:23:33 PDT
checked-in to 1.8.0 branch.

Note You need to log in before you can comment on or make changes to this bug.