Closed Bug 346523 Opened 14 years ago Closed 8 years ago

Delete does not function on document with empty HTML document written to it, then DOM nodes appended, until the editor is used to insert text

Categories

(Core :: DOM: Editor, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jules, Unassigned)

References

Details

(Keywords: testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

If Midas is used to edit a frame whose contents are an empty HTML document (i.e. one in which there is nothing between the <body> and </body> tags), but which has had nodes appended to its body using DOM methods, then delete does not function until additional text is inserted using the editor.

Reproducible: Always

Steps to Reproduce:
1. Create an HTML document with the following content:

<IFRAME id="df_iframe"></IFRAME>
<SCRIPT>
	df_iframe = document.getElementById ("df_iframe");
	df_iframe.contentDocument.write ("<html><head></head><body></body></html>");
	df_iframe.contentDocument.designMode = "on"; 

	var paragraph = document.createElement ("P");
	paragraph.appendChild (document.createTextNode ("Some text to edit."));
	df_iframe.contentDocument.body.appendChild (paragraph);
</SCRIPT>

2.  View the document.
3.  Select some of the text "Some text to edit".
4.  Press "delete"
5.  Position the cursor at the end of the paragraph and press "a"
6.  Repeat steps 3 and 4.

Actual Results:  
Nothing happens at step 4; no deletion takes place until step 6

Expected Results:  
The selected text should be deleted at step 4

If the text written to the document node in the code above is changed to "...<body><p></p></body>..." everything functions as expected.
Confirm, still reproduces in Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/20070211 Minefield/3.0a3pre


See test: http://www.mister-pixel.com/ever/bugs/firefox/midas.346523.html
QA Contact: editor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Blocks: 429308
Duplicate of this bug: 490554
OS: Windows XP → All
WFM with Firefox 6.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.