After DesignMode is turned on, DEL and BkSp keys doesn't work until content is modified

RESOLVED DUPLICATE of bug 346523

Status

()

Core
Editor
RESOLVED DUPLICATE of bug 346523
9 years ago
9 years ago

People

(Reporter: Dusan Halicky, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; sk; rv:1.9.0.9) Gecko/2009042113 Ubuntu/8.04 (hardy) Firefox/3.0.9
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; sk; rv:1.9.0.9) Gecko/2009042113 Ubuntu/8.04 (hardy) Firefox/3.0.9

Can somebody please confirm it is the same bug as described in this minimal
testcase:

http://komiks.xf.cz/bug/cannot_delete.html

It is still present in Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre)
Gecko/20090425 Minefield/3.6a1pre

Or should i file a new bug?

Reproducible: Always

Steps to Reproduce:
   1.  Press "Add sample content" button
   2. Something will appeared in iframe
   3. Select something
   4. Hit DELETE or BACKSPACE key, nothing will happen
   5. Modify it (e.g. add "a" at the end of 2nd line)
   6. Hit DELETE or BACKSPACE key - now it magically works

Actual Results:  
DELETE and BACKSPACE key doesn't work in design mode, first i must type other key

Expected Results:  
DELETE and BACKSPACE should work like other keys

https://bugzilla.mozilla.org/show_bug.cgi?id=462188
Comment 55
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
This doesn't work in 3.0.x as well, I think this might be a dupe.
Component: General → Editor
OS: Linux → All
Product: Firefox → Core
QA Contact: general → editor
Hardware: x86 → All
Whiteboard: DUPEME
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
What do you mean dupe? I test it on 2 different computers on 2 different OS and the bug is real!
Dupe just means that it is a duplicate of another bug previously filed, I can confirm that I see the very same behavior.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 346523
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.