Help Section "Using Bon Echo" -> "Searching" contains old-look Search Bar image

RESOLVED FIXED in Firefox 2

Status

Firefox Graveyard
Help Documentation
--
trivial
RESOLVED FIXED
11 years ago
2 years ago

People

(Reporter: Maxim Radugin, Assigned: mconnor)

Tracking

({fixed1.8.1, late-l10n})

unspecified
Firefox 2
fixed1.8.1, late-l10n
Bug Flags:
blocking-firefox2 +

Details

(Whiteboard: [server side], URL)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060801 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060801 BonEcho/2.0b1

Help Section "Using Bon Echo" -> "Searching" contains old-look Search Bar image from Firefox 1.5.x.x.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox help.
2. Select Using Bon Echo -> Searching

Actual Results:  
Contains old-look Search Bar image

Expected Results:  
Should contain new Search Bar image

Comment 1

11 years ago
We need either a new screenshot or remove it. Note that the UI isn't final yet.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox 2
(Reporter)

Comment 2

11 years ago
Created attachment 231720 [details]
Firefox2 Search bar

Comment 3

11 years ago
Thanks, but that's only the current state. Bug 345407 will make further changes to the searchbar.
Depends on: 345407
(Reporter)

Comment 4

11 years ago
Created attachment 233967 [details]
Firefox2 Search bar

Since bug 345407 is fixed, this one is the final search-bar look
Attachment #231720 - Attachment is obsolete: true

Updated

11 years ago

Comment 5

11 years ago
Requesting blocking to get this either on the radar and landed or off my radar.
Flags: blocking-firefox2?
Axel, why is this on your radar? Do we need new images for all the locales to properly capture the default search engine for each locale? Or is this a straight one-time image replacement
Flags: blocking-firefox2? → blocking-firefox2+

Comment 7

11 years ago
Any help change is on my radar, and for CJKT builds, we may want to use a Yahoo screenshot. All others should actually be fine with a google one.
(Assignee)

Comment 8

11 years ago
This needs to be updated at http://www.mozilla.org/projects/firefox/help/1.1/searchbar.png

This is a web-hosted image, and thus can be replaced after freeze.
Assignee: nobody → mconnor
Whiteboard: [server side]
(In reply to comment #8)
> This is a web-hosted image, and thus can be replaced after freeze.

Not quite; the image is (as its name might slightly indicate) used in Firefox 1.5 as well, so we should really change the URL so 1.5 builds don't start having a funky search bar image.
Created attachment 238368 [details] [diff] [review]
patch v1: URL change

Per comment 9, here's a patch that changes the URL to one which identifies the default search engine in the en-US locale (for en-US, that's searchbar-google.png).  Other locales can leave this as is or change it to reflect their default search engine, as needed (i.e. we can create a searchbar-yahoo.png for CJKT builds).
Attachment #238368 - Flags: review?(mconnor)
Attachment #238368 - Flags: approval1.8.1?
(Assignee)

Comment 11

11 years ago
Comment on attachment 238368 [details] [diff] [review]
patch v1: URL change

not the right fix, we're going to change the baseURL, we've already copied the content over, and will update that content before ship
Attachment #238368 - Flags: review?(mconnor)
Attachment #238368 - Flags: approval1.8.1?
(Assignee)

Comment 12

11 years ago
Created attachment 238452 [details] [diff] [review]
change the baseURL

turns out, we only have a couple of images that we use (searchbar and urlbar) but its better and cleaner to do this anyway!
Attachment #238368 - Attachment is obsolete: true
Attachment #238452 - Flags: review?(gavin.sharp)
Attachment #238452 - Flags: review?(gavin.sharp) → review+
(Assignee)

Updated

11 years ago
Attachment #238452 - Flags: approval1.8.1?

Comment 13

11 years ago
Should this be .org vs .com?
(Assignee)

Comment 14

11 years ago
updated content is checked in, will be live soon.
(Assignee)

Comment 15

11 years ago
(In reply to comment #13)
> Should this be .org vs .com?
> 

Not at this point, its not specific to branded builds, and the rest of the remote help content is there.  We don't currently have a home for Help yet, when we do we can redirect tehre.

Comment 16

11 years ago
Comment on attachment 238452 [details] [diff] [review]
change the baseURL

a=schrep
Attachment #238452 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Comment 17

11 years ago
new images are live, landed branch and trunk
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 18

11 years ago
Post to .l10n to alert localizers?

For those locales that use en-US screenshots, this has late-l10n impact, for those locales that ship localized screenshots in ab-CD.jar, it must not. Thus we can't easily cover this change.
Keywords: late-l10n
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.