ah_crap_handler not called on seg fault on x86_64 FC5

RESOLVED DUPLICATE of bug 346843

Status

()

RESOLVED DUPLICATE of bug 346843
13 years ago
13 years ago

People

(Reporter: mozilla, Assigned: mozilla)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

13 years ago
It looks like the requisite section in nsSigHandlers.cpp is ifdef'd to i386 Linux machines.  ( http://lxr.mozilla.org/seamonkey/source/xpfe/bootstrap/nsSigHandlers.cpp#79 )

I'm testing a patch that adds a check for HAVE_64BIT_OS, because I can't find the spot where the corresponding x86_64 would get set if the machine isn't i386. Looks like maybe I can test for __x86_64__, but I'm not sure.
Component: Build Config → General
Product: Firefox → Core
QA Contact: build.config → general
Version: 2.0 Branch → Trunk
(Assignee)

Comment 1

13 years ago
Created attachment 232059 [details] [diff] [review]
Enable ah_crap on 64bit linux

Check for HAVE_64BIT_OS
Assignee: nobody → mozilla
Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Attachment #232059 - Flags: superreview?(dbaron)
Attachment #232059 - Flags: review?(dbaron)
What's the point given that the stack walking code doesn't work?  (I tried to make it work -- there's a bug somewhere -- but it's pretty far away from being useful.)
(Assignee)

Comment 3

13 years ago
Well, something works now that I have that turned on. On a crash the app just went away. Now I get the sleep() call and am able to attach. So apparently the code in ah_crap_handler is now getting executed and I have valid data in the core that loads up into gdb.

*** This bug has been marked as a duplicate of 346843 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.