Approval: Fx2 pt-BR trademark review - search plugins

RESOLVED FIXED

Status

Mozilla Localizations
pt-BR / Portuguese (Brazil)
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Jeferson Hultmann, Assigned: Gustavo Jr. Alves)

Tracking

({fixed1.8.1})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; pt-BR; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; pt-BR; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

The idea is to replace answers.com by pt.wikipedia and Creative Commons by Domínio Público (a .gov with public domain stuff).

http://lxr.mozilla.org/l10n/source/pt-BR/browser/searchplugins/wikipedia-br.xml
http://lxr.mozilla.org/l10n/source/pt-BR/browser/searchplugins/dominio-publico.xml

google-br.xml, yahoo-br.xml, submarino.xml and mercadolivre.xml came from Fx1.5.

If file names are valid, I'll add files to branch and attach a diff.


Reproducible: Always

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Fx2 pt-BR trademark review - search plugins → Approval: Fx2 pt-BR trademark review - search plugins

Comment 1

12 years ago
from the bit of research i did I think submarino and mercadolivre are good to keep i'm not sure about replacing Creative Commons by Domínio Público. can you provide some further rationale for this move?
thanks
mic
(Reporter)

Comment 2

12 years ago
Actually is not a move, since Fx1.0 and Fx.1.5 don't have Creative Commons search.

The main issue with CC is they don't provide a pt UI (english only?). Even google/yahoo results are in english.
(Reporter)

Comment 3

12 years ago
Created attachment 235467 [details] [diff] [review]
Looks like only dominio-publico.xml is pending.
Attachment #235467 - Flags: approval-l10n?

Comment 4

12 years ago
One of the bigger fishes to try is that none of the MozSearch plugins landed on the MOZILLA_1_8_BRANCH so far.
Sadly, this is now to late in the game with the l10n repository frozen for b2, but this is going to make pt-BT not ship for Firefox 2 B2.
We should boost the traction on this as soon as the l10n repository opens up again.

Updated

12 years ago
Blocks: 348085
(Reporter)

Comment 5

12 years ago
Comment on attachment 235467 [details] [diff] [review]
Looks like only dominio-publico.xml is pending.

So I will wait for a decision.

Anyway, official versions are not important for l10n quality. People who report bugs already use our pt-BR language pack. :-|
Attachment #235467 - Attachment is obsolete: true
Attachment #235467 - Flags: approval-l10n?

Comment 6

12 years ago
any additional thoughts on Domínio Público? meaning have we spoken with them about adding them to our search plug in list? is this a very popular or useful search site for pt?
thanks
mic
(Reporter)

Comment 7

12 years ago
Created attachment 235846 [details] [diff] [review]
google-br, yahoo-br, wikipedia-br, submarino, mercadolivre

As this bug is almost 1 months old and I think it's good for both moz employers and localizers to have this fixed as early as possible, I abandon my request for dominio-publico.xml.
Attachment #235846 - Flags: approval-l10n?

Comment 8

12 years ago
Comment on attachment 235846 [details] [diff] [review]
google-br, yahoo-br, wikipedia-br, submarino, mercadolivre

Please don't add your own google plugin, but just reference the en-US one by simply using 'google' in list.txt.
The Yahoo plugin shouldn't have the en-US suggest url.
From a BD point of view, submarino may prefer a different value for "WhichForm", once we have a contact there, we should verify that.

That'd be my technical review, I guess I prefer a new patch.
Attachment #235846 - Flags: approval-l10n? → approval-l10n-
(Reporter)

Comment 9

12 years ago
Created attachment 235860 [details] [diff] [review]
google-br: removed; yahoo-br: removed suggest <Url>

hmmm... Are you aware that google.com redirs to localized google (making the response slower)? :-|

I'll mail Submarino and ask them if they want to change the form. It's the same shipped with Fx1 and Fx1.5.
Attachment #235846 - Attachment is obsolete: true
Attachment #235860 - Flags: approval-l10n?

Comment 10

12 years ago
Comment on attachment 235860 [details] [diff] [review]
google-br: removed; yahoo-br: removed suggest <Url>

Search order should be good.

Mic, for reference, we have mercadolive.com.br here, which is a sibling of mercadolibre.com.ar, which I suggested for es-AR in bug 348087.
Attachment #235860 - Flags: approval-l10n? → approval-l10n+
(Reporter)

Comment 11

12 years ago
patch committed.

(In reply to comment #10)
> (From update of attachment 235860 [details] [diff] [review] [edit])
> Search order should be good.

Do you mean a patch for region.properties? I'll file a new bug for that.

Comment 12

12 years ago
Not necessary, from what I read in the source, region.properties will do the right thing together with this patch. Should I be wrong about that, I'll file a bug.
(Reporter)

Comment 13

12 years ago
Created attachment 236146 [details] [diff] [review]
remove submarino.xml

I'm waiting for a response from Submarino about the form params.

I've just realized that current Submarino search stopped working. :-| I suggest removing it until the plugin is fixed.
Attachment #236146 - Flags: approval-l10n?

Comment 14

12 years ago
Comment on attachment 236146 [details] [diff] [review]
remove submarino.xml

Sounds good.

Once we find out how to make submarino work, we should consider fixing that on the 1.5.0.x branch, too.
Or remove the plugin, depending on the feedback from submarino itself.
Attachment #236146 - Flags: approval-l10n? → approval-l10n+
(Reporter)

Comment 15

12 years ago
committed. 

Has the timeframe for 1.5.0.7 expired? Would be recommendable remove submarino.src.

Comment 16

12 years ago
Let's resolve this bug, we can have separate bugs for dominio publico and submarino. One each, probably.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 17

12 years ago
Jeferson,
do you have contacts at Submarino and Mercadolivre? I'd like to be able to contact someone there.
thanks
Mic
(Reporter)

Comment 18

12 years ago
I got no response from Submarino. I'm going to file a bug on this issue.

I have made some progress on contacting MercadoLivre (I'm trying to reach the right person).
You need to log in before you can comment on or make changes to this bug.