Closed Bug 347380 Opened 18 years ago Closed 18 years ago

Print dialog broken when using custom date range [Error: jsDateToDateTime is not defined]

Categories

(Calendar :: Printing, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: ssitter)

Details

Attachments

(1 file, 1 obsolete file)

Print dialog broken when using custom date range [Error: jsDateToDateTime is not defined]

Steps to Reproduce:
1. Start Sunbird, select events
2. Select 'File -> Print...' command
3. Set 'Range to print' to 'Custom'
4. Press OK button

Actual Results:
Nothing happens. Error message shown in console:
    Error: jsDateToDateTime is not defined
    Source File: chrome://calendar/content/printDialog.js Line: 139

See also Bug 345606, probably same problem.

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060804 Calendar/0.3a2+
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #232148 - Flags: first-review?(jminta)
Comment on attachment 232148 [details] [diff] [review]
use window.opener.jsDateToDateTime

I think we really just want to not remove calendarUtils.js from the xul file.  I removed it because I *thought* that the composite stuff was the only reason it was needed, forgetting about the jsDate conversion here.  However, I've been on airplanes for the last 12hrs, so I may be completely off base here.
Attachment #232148 - Attachment is obsolete: true
Attachment #232560 - Flags: first-review?(jminta)
Attachment #232148 - Flags: first-review?(jminta)
Comment on attachment 232560 [details] [diff] [review]
add calendarUtils.js back to xul

r=jminta, thanks for the patch!
Attachment #232560 - Flags: first-review?(jminta) → first-review+
Whiteboard: [checkin needed]
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.