All users were logged out of Bugzilla on October 13th, 2018

Flashing caret disappears after Delete or Cut

VERIFIED DUPLICATE of bug 29843

Status

()

P3
normal
VERIFIED DUPLICATE of bug 29843
19 years ago
17 years ago

People

(Reporter: wmccain, Assigned: sfraser_bugs)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; Win98; en-US; m14) Netscape6/6.0b1
BuildID:    2000033112

After deleting a block of text in the URL entry box at the top of the Web
browser, the flashing "insert cursor" sometimes disappears.  If you then attempt
to insert new text from the system clipboard, it looks like "nothing happens".
However, the flashing "insert cursor" suddenly reappears when you type a
character of text.

This phenomenum appears to be related to using the mouse to select a block of
text that is larger than the text entry box (by "scrolling" the text as it is
selected for deletion.

The same thing happens with the text boxes on Web pages that have HTML FORMs.


Reproducible: Always
Steps to Reproduce:
1. Load a Web page with a long URL.
2. Re-size the browser window so that the URL text box is too small to display
the URL entirely (without scrolling).
3. Use the mouse to select the ENTIRE URL (by scrolling the text as it is selected).
4. Press the "Delete" key on the keyboard (or Ctrl-X for "Cut").


Actual Results:  The text is deleted, but the flashing "insert cursor"
disappears.  A subsequent attempt to use the Ctrl-V "Paste" key to insert text
from the system clipboard produces no visible result.  However, when a data key
is typed, it does appear -- along with the flashing "insert cursor" and the
previously inserted text from the system clipboard (if any).

Expected Results:  The flashing "insert cursor" should remain visible after
Delete or Cut.  The "pasted" text from the system clipboard should be visible
immediately upon insertion.
(Reporter)

Updated

19 years ago
Summary: Flashing "insert cursor" disappears. → [4.xP] Flashing "insert cursor" disappears after Delete or Cut.

Comment 1

19 years ago
wmccain@metaconnect.com, this is not the place for Netscape bugs.  While 
Netscape may be a fine place to report mozilla bugs, the inverse does not hold 
true.  Please report your issues with the Netscape product by selecting the 
Feedback item in the Help menu.  Thanks for your help in testing.

Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 2

19 years ago
Marking bugs as invalid just because they were found in the Netscape-branded
version is a great way to alienate users.  See bug 34767.

Asa, are you sure this bug happens only in Netscape-branded versions?  If not,
please re-mark it as WORKSFORME instead of as INVALID.
(Reporter)

Comment 3

19 years ago
As per your request, I tried to submit this bug report via the "Help Feedback"
route.  This process was clearly more oriented toward end users -- whereas I
have been a professional software engineer for over THIRTY YEARS.  After a great
deal of "pruning" my bug report (the Feedback form kept rejecting it for being
over 1000 characters) I finally got it past the initial "form screening".  Then
it got rejected with a "Server Error".  REPEATEDLY (about 10 times).

So I am "giving up" on that route.

Honestly, I don't understand why you are being so picky about taking this
completely valid bug report -- which is 100% reproducible.  I waited until
today, when the first external Beta of your new Web browser was released, to
begin testing its compatibility with Web pages produced by my product (NetWare
HostPublisher from Novell, Inc.).  I immediately found five or six bugs, several
of them "blockers" (much more critical than this one).  Since I have often used
the Netscape "DevEdge Online" Web site in the past, I looked around there for a
mechanism to report bugs in Netscape 6.  I quickly found out about Bugzilla,
opened a Bugzilla account, and reported all the bugs I had found.

I hope I am not "stepping on any toes", but as far as I am concerned mozilla ==
Netscape!!!


Comment 4

19 years ago
Reporter, Netscape took Mozilla code from nearly 5 weeks ago and began working 
with it internally and not accepting new development while Mozilla progressed.  
Many of the bugs that are found in Netscape's branded version do not exist or 
have been fixed in Mozilla in the last month of development. If you would like 
to grab a current nightly build or Milestone release of Mozilla and test that 
then please do and report any bugs you discover to Bugzilla.  Bugzilla cannot 
and will not be able to address problems that exist in Netscape's products.  I 
agree that some of the issues that are discovered in Netscape's product may stem 
from problems in mozilla but the proper way to test and report that is with 
Mozilla builds and not Netscape builds.  We would love to have your input 
regarding Mozilla.  I'm sure that Netscape would appreciate your input regarding 
their 6.0 product.  Netscape is not Mozilla. 

Comment 5

19 years ago
* Inane 1KB text limit submitted to Marketing as (private) bug #34828. 

* The fact that the Feedback Center form has been busted has been submitted via 
manager, as I was too disgusted to do it myself with any degree of tact.
(Reporter)

Comment 6

19 years ago
As requested, I have downloaded the most recent milestone build of mozilla and
have re-verified this bug there.  Build ID: 2000022820.

The reported bug is indeed present in the mozilla milestone build, and it
operates (and isolates) exactly as I previously reported.  Since I have
determined that the bug is consistently invoked by "selecting and deleting" a
line of text that is longer than the text entry box, it should be fairly easy
for you to reproduce it and fix it.

As a professional software developer with LONG experience, I try not to waste
people's time reporting bugs that I have not first isolated into a reproducible
scenario.  Many are the times I myself have torn my hair out trying to fix a
problem reported by customers with "problem conditions" that turned out to be
"red herrings" -- and the true conditions that led to the bug were not reported
(or even guessed at) by the customer or technical support personnel!

I would greatly appreciate it if you would re-open this bug.

Comment 7

19 years ago
I was able to reproduce this bug on 2000 040610 (Win 98), so reopening.  Thanks 
for sticking in there, wmccain.

New steps to reproduce:
1. Type enough stuff into the location bar or a text box so that the text can't 
all be displayed at once.
2. Select more than a textboxfull of text, starting from the left.  (Starting 
from the left means you see the right end of the selection when you finish.)
3. Press delete or ctrl-X (cut), or select "cut" from the edit menu.  (Shift-
delete doesn't show this bug; see my comments on bug 20298.)

A similar bug exists with the "undo" and "redo" commands.  Hopefully this other 
bug will fix itself when this one gets fixed.
URL: [none]
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(Reporter)

Comment 8

19 years ago
Thanks for verifying, davidr8.  I see that it's status is now "UNCONFIRMED" --
needs to be "promoted" to "NEW", I guess.

You might want to close 35061 as a "DUP" now.  35061 is a new report that I
opened against Mozilla build 2000022820 when I had given up on anyone re-opening
34761. :-)

On a lighter note, do you have any way of getting somebody to look at three much
more serious bugs that I submitted a few days ago?  I admit that this one
(34761) is kinda a "nit" (and *I* am a nit-picker).  But these other three are
real show-stoppers for me.  They have prevented me from doing any serious
testing of my product against Mozilla (aka Netscape 6) -- and I have confirmed
all three of them on BOTH the most recent Mozilla milestone build AND the
"Netscape branded version".

The bug report numbers are 34740, 34746, and 34753.  There has been no response
or any other activity on them since they were submitted -- yet they are far more
critical than 34761!

A simple way to produce all three bugs is to go to the following Web page and
try my product demos -- Demos #1, #2, and #3 all fail (Demo #4 works okay).  In
fact, Demo #2 fails so bad it "locks up Mozilla" and you have to Ctrl-Alt-Del to
abort the app and then re-start it.  These demos all work perfectly under all
recent and current releases of Communicator and MSIE, of course.  My bug reports
34740, 34746, and 34753 correspond to the failure of Demos #1, #2, and #3,
respectively.  The Web page is:

http://www.novell.com/products/host/infopub/demos.html

Note: I don't actually work for Novell anymore.  I retired last summer after 30
years as a software engineer in Silicon Valley.  But I do consult for my former
employer from time to time.
(Reporter)

Comment 9

19 years ago
*** Bug 35061 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

19 years ago
I was able to change 35061 to a DUP of 34761, myself.  But this tracking system


would not let me re-open or re-assign 34761, even though I was the submitter!





Confirming as requested. BTW, NS 6 feedback form _should_ now be fixed.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 12

19 years ago
I'm pretty sure editor folks have a bug that covers this but I didn't find it. 
->Editor and reassign.
Assignee: asadotzler → beppe
Component: Browser-General → Editor
QA Contact: jelwell → sujay

Comment 13

19 years ago
->mjudge
Assignee: beppe → mjudge
Keywords: 4xp
Summary: [4.xP] Flashing "insert cursor" disappears after Delete or Cut. → Flashing caret disappears after Delete or Cut
Target Milestone: --- → M16

Comment 14

19 years ago
joe you have one of these i think. resolve this one as a dup of that one. thx
Assignee: mjudge → jfrancis
(Assignee)

Comment 15

19 years ago
Taking this. Jeeez, what a lot of noise.
Assignee: jfrancis → sfraser
(Assignee)

Comment 16

19 years ago


*** This bug has been marked as a duplicate of 29843 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → DUPLICATE

Comment 17

19 years ago
verified in 4/20 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.