Firefox crashes browsing "Penny Arcade" after latest patch [@ libflashplayer.so]

RESOLVED WORKSFORME

Status

defect
--
critical
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: u71076, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, )

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

After the latest patch (version 1.5.0.6) was applied to my Firefox install, the browser now crashes if I try to browse the Penny Arcade website (http://www.penny-arcade.com). 

I don't know how helpful it is, but these crashes have been submitted via the "Mozilla Quality Feedback Agent" with Incident IDs such as TB21873076E, TB21871752Y, and TB21873091Z.

This crash is happening every single time I try to use the Penny Arcade site with the new patch. In the course of testing steps for this bug, I just crashed the browser a couple dozen times.

Reproducible: Always

Steps to Reproduce:
An example of "browsing" which causes a crash:
1. I have http://www.penny-arcade.com/comic set as one of my homepage tabs.
2. From this page, click the "Penny Arcade" banner which links to http://www.penny-arcade.com
3. If this doesn't cause a crash, click one of the hyperlinks in the text. For example, the front page currently contains a link to http://www.penny-arcade.com/comic/2006/08/07

Comment 1

13 years ago
So you're crashing completely within Flash. I find it really hard to believe that upgraded along made this start crashing.

Can you download 1.5.0.4/5 and see if it was indeed a regression?

Incident ID: 21873091
Stack Signature	libflashplayer.so + 0xcba32 (0xb26a2a32) 7d755ab9
Product ID	Firefox15
Build ID	2006072814
Trigger Time	2006-08-07 11:49:59.0
Platform	LinuxIntel
Operating System	Linux 2.6.12-10-386
Module	libflashplayer.so + (000cba32)
URL visited	
User Comments	
Since Last Crash	0 sec
Total Uptime	8 sec
Trigger Reason	SIGSEGV: Segmentation Fault: (signal 11)
Source File, Line No.	N/A
Stack Trace 	
libflashplayer.so + 0xcba32 (0xb26a2a32)
libflashplayer.so + 0xce605 (0xb26a5605)
libflashplayer.so + 0xd14a1 (0xb26a84a1)
libflashplayer.so + 0xd154b (0xb26a854b)
libflashplayer.so + 0xd154b (0xb26a854b)
libflashplayer.so + 0xd154b (0xb26a854b)
libflashplayer.so + 0xb2d72 (0xb2689d72)
libflashplayer.so + 0xb306c (0xb268a06c)
libflashplayer.so + 0x1052df (0xb26dc2df)
libflashplayer.so + 0x104a43 (0xb26dba43)
libflashplayer.so + 0x105237 (0xb26dc237)
libflashplayer.so + 0xf9a6a (0xb26d0a6a)
libflashplayer.so + 0x1387dc (0xb270f7dc)
libflashplayer.so + 0x17ca29 (0xb2753a29)
libglib-2.0.so.0 + 0x26006 (0xb7928006)
libglib-2.0.so.0 + 0x244ee (0xb79264ee)
libglib-2.0.so.0 + 0x274f6 (0xb79294f6)
libglib-2.0.so.0 + 0x277e3 (0xb79297e3)
libgtk-x11-2.0.so.0 + 0x11de65 (0xb7bcfe65)
nsAppShell::Run()  [/builds/tinderbox/Fx-Mozilla1.8.0-Release/Linux_2.4.21-37.EL_Depend/mozilla/widget/src/gtk2/nsAppShell.cpp, line 141]
nsAppStartup::Run()  [/builds/tinderbox/Fx-Mozilla1.8.0-Release/Linux_2.4.21-37.EL_Depend/mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 151]
XRE_main()  [/builds/tinderbox/Fx-Mozilla1.8.0-Release/Linux_2.4.21-37.EL_Depend/mozilla/toolkit/xre/nsAppRunner.cpp, line 2376]
main()  [/builds/tinderbox/Fx-Mozilla1.8.0-Release/Linux_2.4.21-37.EL_Depend/mozilla/browser/app/nsBrowserApp.cpp, line 62]
libc.so.6 + 0x14ec2 (0xb7458ec2)
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: general → plugins
Summary: Firefox crashes browsing "Penny Arcade" after latest patch → Firefox crashes browsing "Penny Arcade" after latest patch [@ libflashplayer.so]
Version: unspecified → 1.8 Branch
Reporter

Comment 2

13 years ago
(Somehow I think I downloaded an Arabic version of 1.5.0.4, which was a fun experience...)

I couldn't get the browser to crash on 1.5.0.4. On 1.5.0.6, it's still trivial to crash it.

If you're not able to reproduce the problem on 1.5.0.6 is there some way I can turn on debugging to produce a stack trace?

Comment 3

13 years ago
I am finding a very similar thing. Penny-arcade causing all instances of firefox to disappear - usually when I open the latest comic in a tab. It does not happen 100% of the time and it has only started doing this recently (last month or 2).

Firefox 1.5.0.5
Ubuntu Drapper (with all the latest updates) - 2.6.15-26-386


I'm happy to do tests (stack traces and such) by request.

Comment 4

13 years ago
You should be able to grab the Firefox debug package from Ubuntu (firefox-dbg or something). This will give you debugging symbols for Firefox. 

Then you can do something like:

./firefox -g -d gdb
handle SIG33 noprint nostop
run
<crash>
where

That should give you a stack (with symbols, hopefully) that you can paste or attach to this bug.
Reporter

Comment 5

13 years ago
I'm just running Firefox that I downloaded from mozilla.com (firefox-1.5.0.6.tar.gz). I've looked around on the developer pages, but I haven't found a similar 'debug' download. Could you provide a URL?

Comment 6

13 years ago
Ah, sorry. I was assuming you were using the Ubuntu Firefox package. If you're not using a package, you'll have to compile your own debug build, which isn't all that easy...

Comment 7

13 years ago
Also occurs on latest stable Mozilla (1.7.13).

*** This bug has been marked as a duplicate of 200511 ***
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE

Comment 9

13 years ago
this may be a dupe of bug 334501, but not bug 200511.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

13 years ago
what version of flash plugin are the people that can repro this using?

Comment 11

13 years ago
(In reply to comment #10)
> what version of flash plugin are the people that can repro this using?
> 

I did a quick search in Synaptic and it looks like I've got a few flash things installed. How do I know which one Firefox is using? 

Incidently, I've started using Epiphany, and I can browse Flash sites fine with it.
(In reply to comment #11)
> I did a quick search in Synaptic and it looks like I've got a few flash things
> installed. How do I know which one Firefox is using? 

You can find the information on the plugins info page. Enter 'about:plugins' into the location bar and search for Flash.
flash v7 for linux is known to crash.

current version is Flash 9.0 r31
does it solve your crash?
Reporter

Comment 14

13 years ago
I haven't seen this crash since upgrading to Flash 9.0 r31. WORKSFORME?
Status: NEW → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: 1.8 Branch → unspecified
Crash Signature: [@ libflashplayer.so]
You need to log in before you can comment on or make changes to this bug.