Closed Bug 348254 Opened 14 years ago Closed 13 years ago

Some accesskeys are unreachable in Sunbird Preferences window

Categories

(Calendar :: Preferences, defect)

Sunbird 0.3a2
x86
Linux
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: cedric.corazza, Unassigned)

References

Details

(Keywords: access)

Attachments

(1 file, 3 obsolete files)

The bug 347813 added accesskeys in the Preferences window but some of them are unreachable with ALT+Key.
I don't ask review because this patch doesn't fix all the issues. It allows all the accesskeys to be reached and removes duplicate IDs.
The remaining issue is all works fine the *first* time you access a pane (General, Alarms, ...); for instance, accesskeys are functional if you go first in General, then in Alarms, then in Categories, but if you go back to a panel already seen, some of them don't work anymore. I couldn't figure out why. If anyone has a clue...
(In reply to comment #1)
> I don't ask review because this patch doesn't fix all the issues. It 
> allows all the accesskeys to be reached and removes duplicate IDs.

I think removing duplicate IDs and fixing some issues is good. 
You should ask for review.
Asking for review as suggested by Stefan
Attachment #233128 - Attachment is obsolete: true
Attachment #234922 - Flags: first-review?(mattwillis)
Comment on attachment 234922 [details] [diff] [review]
New patch as views.xul has been modified since

> -                <label value="&pref.dateformat.label;"
> -                       accesskey="&pref.dateformat.accesskey;"
> -                       control="dateformat"/>
> +                <label accesskey="&pref.dateformat.accesskey;" control="dateformat">&pref.dateformat.label;</label>

Why are you changing the format of the tag? Does this change fix the accesskey?

I've got some style nits also, but I'll wait to see what the answer to the above is.
I made all the tests again :
Only removing the duplicate IDs doesn't fix anything, but we do not want duplicates, right ? So I renamed them.
I guess I finally found why these accesskeys were unreachable. It seems that the accesskey attribute do not work inside a caption entity, so I replaced all caption entities containing accesskey attributes by label entities.
I tested that and it worked (though the behaviour described in comment #1 still occurs).
Attachment #234922 - Attachment is obsolete: true
Attachment #236256 - Flags: first-review?(mattwillis)
Attachment #234922 - Flags: first-review?(mattwillis)
Comment on attachment 236256 [details] [diff] [review]
Switching caption entities for label entities

This looks good. The only nit I have is that you should align the properties. If you were trying to not mess up cvs blame, I commend your intentions. :)

>Index: base/content/preferences/alarms.xul
>===================================================================
>-                            <caption label="&pref.defalarm4events.label;"
>+                            <label value="&pref.defalarm4events.label;"
>                                      accesskey="&pref.defalarm4events.accesskey;"
>                                      control="eventdefalarm"/>

So in this example, move accesskey and control two spaces to the left to align them beneath value.

r1=lilmatt with that fixed throughout the patch
Attachment #236256 - Flags: first-review?(mattwillis) → first-review+
This patch adresses the nits lilmatt asked for.
Attachment #236256 - Attachment is obsolete: true
Attachment #237144 - Flags: second-review?(jminta)
Attachment #237144 - Flags: first-review+
Comment on attachment 237144 [details] [diff] [review]
Switching caption entities for label entities v2

Nice work. r2=jminta
Attachment #237144 - Flags: second-review?(jminta) → second-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
(In reply to comment #0)
> The bug 347813 added accesskeys in the Preferences window but some of them are
> unreachable with ALT+Key.

still missing for:
1. Dropdown list in timezone panel
2. Add Category dialog (none)
3. Categories -> Edit - there is acceskey for edit button but if you select category edit does not work, remove works

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #10)
> (In reply to comment #0)
> > The bug 347813 added accesskeys in the Preferences window but some of them are
> > unreachable with ALT+Key.
> 
> still missing for:
> 1. Dropdown list in timezone panel
I don't know all the rules for accesskeys, but this panel has only one item, so a single tabulation is enough to reach it. I don't thing it's necessary to add an accesskey there, but I maybe wrong.

> 2. Add Category dialog (none)
This bug was intended for the main prefs window, not for sub-windows/dialogs. Same comment as above: only one item. Well, this might belong to another bug I think.

> 3. Categories -> Edit - there is acceskey for edit button but if you select
> category edit does not work, remove works
This is a known issue (cf. comment #1). Anyway, it has been approved that the current fix was better than the one for bug 347813 as it resolved some additional issues.

Regards

Calendars Owners and Peers: could we close this bug again ?


Depends on: 143065
(In reply to comment #11)
> Calendars Owners and Peers: could we close this bug again ?

I think this bug can be resolved fixed again. I tested with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3pre) Gecko/20070310 Calendar/0.5pre and don't see the issue reported in point 3 Comment #10. With the other points I agree with Cédric.
Status: REOPENED → RESOLVED
Closed: 13 years ago13 years ago
Resolution: --- → FIXED
Verified using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.3pre) Gecko/20070320 Calendar/0.5pre
Status: RESOLVED → VERIFIED
Component: Sunbird Only → Preferences
QA Contact: sunbird → preferences
You need to log in before you can comment on or make changes to this bug.