Closed Bug 34841 Opened 25 years ago Closed 25 years ago

Scrollbar context menu is invalid.

Categories

(Core :: XUL, defect, P3)

x86
Linux
defect

Tracking

()

VERIFIED DUPLICATE of bug 30497

People

(Reporter: ccurtis0, Assigned: trudelle)

References

()

Details

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.13 i586; en-US) Mozilla/m13
BuildID:    2000031520

This appears to be most repeatable when mozilla is first started.  At first, I
thought it was only when the wrong cursor was displayed, but I get it with the
arrow cursor as well:  Right-clicking anywhere in the scrollbar (arrow, slider,
or grey area) will popup a context manu that contains every available option,
such as "Save Image As...", "Save Frame As...", "Save Link As...", etc.

Additionally, menu items are not reset.  You can select "View Image" and the
menu disappears and mozilla does not crash.  Right clicking again to redisplay
the menu shows that item still highlighted, and you can select another item.
Each item in succession is highlighted so that there are many highlights in the
menu.  I'm not sure if this is a bug that should be fixed or simply manifests
itself because of other bugs.


Reproducible: Sometimes
Steps to Reproduce:
1. Open Mozilla
2. Move mouse into scrollbar
3. Right-click with the mouse


Actual Results:  Popup menu appeared

Expected Results:  No menu.


Actually, if you right-click on the page and then right click on the scrollbar
the menu for the page appears on the scrollbar, so it looks like mozilla is
trying to do the right thing by displaying the same menu, it just hasn't been
initialized yet.

It seems that this is the behavior on any new page so it should be reprodcable
by simply going to a new page and right clicking the scrollbar.
dup of bug #30497 

*** This bug has been marked as a duplicate of 30497 ***
Status: UNCONFIRMED → RESOLVED
Closed: 25 years ago
Resolution: --- → DUPLICATE
verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.