Closed Bug 30497 Opened 21 years ago Closed 21 years ago

Right clicking on scrollbar while dragging it causes a assertion

Categories

(Core :: XUL, defect, P2)

x86
Windows 95
defect

Tracking

()

VERIFIED WORKSFORME
Future

People

(Reporter: bratell, Assigned: hyatt)

References

Details

(Keywords: relnote, Whiteboard: [PDT-])

If you happens to press the right mouse button while dragging a scrollbar, more 
exactly the main scrollbar in the browser window, you gets an assertion "Not yet 
implemented" from nsXULElement::GetStyle(nsIDOMCSSStyleDeclaration** aStyle). 
Ignoring that assertion all strange things starts to happen (javascript errors 
and others).


Reproducible: Always
Steps to Reproduce:
1. Start mozilla and load a page thats too long for the window.
2. Drag the scrollbar, but do not release the left mouse button.
3. Press the right mouse button.

Actual Results:  An assertion

Expected Results:  Mozilla should not react to a right mouse button press while 
dragging something.

This was with a CVS build from 2000-03-05 but I have seen this some time.
I'm nominating this for beta since this happens me very often and always ends in 
having to restart the browser. I know it depends on your mouse and your style 
how often you happen to press the right mouse button by mistake, but I'm sure 
there are many with the same problem out there.
Keywords: beta1
I disagree completely, this scenario is so unlikely that I expect you're the 
only one to ever see it. If I'm wrong, it should be easy to prove by pointing to 
other crashes in Talkback. This is not worth the risk of fixing this close to 
beta1. 
You might be right that I'm unique but I don't think you'll see anything in the 
talkback as assertions aren't in release builds (or has that changed?). What 
will happen is the JavaScript error and then a lot of strange things and finally 
there might be an ordinary crash, but it seems to be at different places almost 
every time.
Peter, this is either an Eric bug or someone in the browser group.
Thanks RodS, but I wanted to test this first.  Crash may only be happening on 
Win2K; I can't reproduce on Win98 or Linux, and Mac doesn't have a right button.
Bringing up context menu in this exact circumstance is incorrect though, and may 
not ever be appropriate for scrollbars (other bug reports cover the general 
case). Assigning to evaughan as p2 for M15, cc law
Assignee: trudelle → evaughan
Priority: P3 → P2
Target Milestone: M15
Putting on PDT- radar for beta1.  will relnote for beta1.
Keywords: relnote
Whiteboard: [PDT-]
*** Bug 30839 has been marked as a duplicate of this bug. ***
I just noticed that Netscape 4.72 _has_ a popupmenu for the scrollbar. How 
strange. It contains "Scroll here", "Top", "Bottom", "Page Up", "Page Down", 
"Scroll Up", "Scroll Down". If Mozilla will have popups for scrollbars, that 
would as good items in the menu as any.
Hyatt,

This happens because it trys to popup a popup. Why would it try to do that?

-E
Assignee: evaughan → hyatt
Status: NEW → ASSIGNED
Target Milestone: M15 → M17
Mass moving M17 bugs to M18
Target Milestone: M17 → M18
*** Bug 34841 has been marked as a duplicate of this bug. ***
The assertion and the uncaught exception in js are the same bug (which is 
actually covered in bug #7639  ---- XULElement::GetStyle is indeed not 
implemented).

This is not specfic to win2k; I get the same behaviour on win95, but on neither
platform do I get a crash in a release build (leaving aside the assertion).

I note though, that win2k does provide a new popup menu on native scrollbars
(as described above).

By the way, I see that joki fixed bug #23373 with a change to 
nsXULPopupListener.cpp that makes preventDefault work -- is this 
what was needed to fix this bug?
Severity: critical → normal
OS: Windows 2000 → Windows 95
Summary: Right clicking on scrollbar while dragging it causes a crash → Right clicking on scrollbar while dragging it causes a assertion
mass-moving all '-' bugs to M20
Target Milestone: M18 → M20
Target Milestone: M20 → Future
*** Bug 46441 has been marked as a duplicate of this bug. ***
Daniel: that popup menu you're seeing for scrollbars in NS 4.x is just the 
generic win2k context menu for native scrollbars.

Eric: I noticed you said that this was caused because it was trying to bring up 
a popup menu.  Now that bug 27289 has been fixed for the scrollbar, and soon 
the thumb, is this bug valid anymore?
the code in nsContextMenu.js now avoids using .style on a XUL element, so this
assertion is no longer triggered. Marking worksforme.
Status: ASSIGNED → RESOLVED
Closed: 21 years ago
Resolution: --- → WORKSFORME
Works for me
Status: RESOLVED → VERIFIED
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.