Extensions Should Be Able to Add and Handle Columns

RESOLVED FIXED

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Oren Nachman, Assigned: Oren Nachman)

Tracking

({fixed1.8.1})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 3 obsolete attachments)

(Assignee)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

It is currently extremely difficult (and slow) for extensions to add or control columns in the mail window.

Reproducible: Always



Expected Results:  
A native interface should exist allowing extensions to add and modify columns in the mail window.
(Assignee)

Comment 1

12 years ago
I am currently working on this - via the SoC program.
(Assignee)

Comment 2

12 years ago
Created attachment 233578 [details] [diff] [review]
Adds custom column handler functionality

This basically implements a number of files that can be accessed via javascript allowing an extension to easily add column handlers. See (patched) nsIMsgDBView.idl:338 for more information.

Comment 3

12 years ago
Created attachment 234876 [details] [diff] [review]
more wip
Attachment #233578 - Attachment is obsolete: true
(Assignee)

Comment 4

12 years ago
Created attachment 235655 [details] [diff] [review]
Update to Columns

Added support for:

1. isString()
2. colHandler is now passed into GetCollationKey and GetLongField - this stops it being looked up once per email.
(Assignee)

Comment 5

12 years ago
Created attachment 236074 [details] [diff] [review]
Added an id to treecols

This small patch adds an id to the treecols tag in mail/base/messenger.xul, allowing easy appending of columns to the previous columns. The previous patches are basically useless without this.
(Assignee)

Updated

12 years ago
Attachment #235655 - Attachment is obsolete: true
(Assignee)

Updated

12 years ago
Attachment #236074 - Attachment is obsolete: true
(Assignee)

Comment 6

12 years ago
Created attachment 236079 [details] [diff] [review]
All inclusive patch

Previous patch missed the changes to the mail/ directory (commandglue.js), rendering them quite unusable. This patch includes:

1. commandglue properly handles custom columns
2. messenger.xul has the extra id required to allow for easy column appending
3. Fixed crashes (reference counters) and linking errors (dbienvenu)

Comment 7

12 years ago
re-assigning to Oren - I'm going to start landing parts of this, sr=me...
Assignee: mscott → nachmore
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 8

12 years ago
Is this feature really TB-specific or should the bug be recategorized as Core?

Comment 9

12 years ago
Created attachment 236551 [details] [diff] [review]
patch checked in 

this is the patch as checked in - I made some tweaks to the previous patch:

1. Cleaned up some braces
2. Got rid of one of the overloaded GetLongField/GetCollationKey methods, and used a default nsIMsgCustomColumnHandler = nsnull instead.
3. Added a license header to the new nsIMsgCustomColumnHandler.idl
4. Fixed a windows compile error - windows doesn't like variables defined in the cases of switch statements, w/o surrounding {}
Attachment #236551 - Flags: superreview+

Comment 10

12 years ago
This broke all columns :(
Something wrong in check-in?
(Assignee)

Comment 11

12 years ago
I just did a clobber build and all the columns work fine for me. What system are you on? And are you running any other type of patch?

Small note: the checked in patch misses the small update to messenger.xul which allows easy addition of columns. Not sure if I am missing some way of adding columns or not though...
Status: NEW → ASSIGNED

Comment 12

12 years ago
Sorry, after full rebuild it seems to work.

Comment 13

12 years ago
fix checked into trunk and branch. Thanks, Oren!
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Comment 14

12 years ago
(In reply to comment #13)
> fix checked into trunk and branch. Thanks, Oren!
> 

is it possible to get the change to messenger.xul checked in as well? Without it attaching columns to the existing set is problematic...

Updated

12 years ago
Depends on: 351464

Updated

12 years ago
Blocks: 360488

Updated

11 years ago
No longer blocks: 360488

Updated

11 years ago
Duplicate of this bug: 345243
You need to log in before you can comment on or make changes to this bug.