Closed Bug 348637 Opened 13 years ago Closed 13 years ago

layered components "bleed through" when "allow pages to choose own colors" is unchecked or in high contrast mode

Categories

(Core :: CSS Parsing and Computation, defect, major)

defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 255411
mozilla1.9alpha6

People

(Reporter: gibson.becky, Assigned: dbaron)

References

(Blocks 1 open bug, )

Details

(Keywords: access)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

When elements are layered over one another, the background color becomes transparent when the operating system is put into high contrast mode.  
Set your Windows OS to high contrast mode and load the google suggests url.  When you start typing and the drop down occurs, the background is still visible below the drop down.  The background of the drop down should be solid and not bleed through.  

Reproducible: Always

Steps to Reproduce:
1.Set Windows OS to high contrast mode 
2.start FF and load http://www.google.com/webhp?complete=1&hl=en
3. when you type drop down of suggestions appears - note that the background of the drop down is not solid and the elements beneath it are visible.

Actual Results:  
elements underneath the drop down are visible

Expected Results:  
The background of the drop down should be solid.  

IE had this problem in early releases of IE 6. They released a patch and it has been fixed in IE 6 updates.
Keywords: access
Component: Disability Access → Layout
Product: Firefox → Core
Version: unspecified → 1.0 Branch
Blocks: keya11y
When you set high contast on in Windows, we automatically act as if the pref "allow pages to choose their own colors, instead of my selections above" is unchecked.

Is this bug dependent on high contrast or just that pref in general?
The bleed through will also occur in "normal" display (with NO high contrast mode set).  Just uncheck the checkbox "allow pages to choose own colors instead of my selections above" on the Tools Options General Colors panel.  Issue can be seen at the same google suggests URL.

updated the severity to major because this makes development of accessible drop down menus impossible
Severity: normal → major
Summary: layered components "bleed through" in high contrast mode → layered components "bleed through" when "allow pages to choose own colors" is unchecked and in high contrast mode
Version: 1.0 Branch → 1.8 Branch
Summary: layered components "bleed through" when "allow pages to choose own colors" is unchecked and in high contrast mode → layered components "bleed through" when "allow pages to choose own colors" is unchecked or in high contrast mode
This should block 1.9 at least.
Flags: blocking1.9?
QA Contact: disability.access → layout
Blocks: themea11y
No longer blocks: keya11y
To fix this we'd need to completely change the way we implement that pref, so that we essentially convert all non-transparent backgrounds into the default background color, but leave any backgrounds that are transparent as transparent.

(Although we might be able to do some fun CSS extension that would allow us to express that in CSS.)
I think this is a duplicate, though.
Assignee: nobody → dbaron
Component: Layout → Style System (CSS)
QA Contact: layout → ian
Flags: blocking1.9? → blocking1.9+
Hrm, I couldn't find the bug I remembered, although bug 58048 and bug 255829 are other bugs on this feature.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: 1.8 Branch → Trunk
Another good example of this problem is amazon.com: mouse over "See All Product Categories".

Possible duplicates include 348957 322664 370485.
Duplicate of this bug: 370485
Duplicate of this bug: 322664
Target Milestone: --- → mozilla1.9alpha6
Depends on: 374907
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 255411
(I'll attach the more accurate fix I was planning to bug 58048.)
Flags: blocking1.9+
Flags: blocking1.9+
The problem got fixed by unchecking "always use my colors" box. The problem doesn't occur with the default colors.
You need to log in before you can comment on or make changes to this bug.