Unable to consistently remove tags from IMAP mail messages

RESOLVED FIXED

Status

MailNews Core
Networking: IMAP
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: reid, Assigned: Bienvenu)

Tracking

({verified1.8.1.1})

Trunk
x86
All
verified1.8.1.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060815 Thunderbird/2.0a1 ID:2006081504

When I tag a mail message ("to do" say), it turns blue as it should.  Then if I right-click on the message in the index, select "Tag->0 Remove All Tags" or just uncheck the tag, the message is no longer blue; however, if I scroll around, the tag inevitably comes back.  Sometimes removing the tag will actually become permanent, but I don't know how I've done it.  Most times it doesn't work.  This is also true if I right-click on the displayed body of the message itself or use the "Message" menu.

Reproducible: Sometimes

Steps to Reproduce:
1.Assign a tag to a message.
2.Try to remove it.
3.

Actual Results:  
Tag will appear to be removed, but scrolling or displaying all messages with that tag will show that the message still has the tag.

Expected Results:  
The tag should be removed.

In case it matters, I'm using an IMAP server.  Restarting Thunderbird doesn't help.  I don't see anything relevant in the error console.  I hope I'm not just doing something stupid, since I didn't see any other bug reports about this!

Comment 1

12 years ago
I get this bug as well on the latest Mac builds, also with an imap server.

Comment 2

12 years ago
Still seeing this bug in the latest builds.  But it appears this only bites me on the 'Important' tag.  Other tags are easily removed and stay gone.

Comment 3

12 years ago
Forget what I said about it only being the 'Important' tag.  However, it appears if I remove the tag, verify that the imap keyword doesn't exist anymore on that message on the imap server, and then 'Rebuild the index' on that folder in Thunderbird, it finally stays gone.

Comment 4

12 years ago
Okay, more information.  If I use 'Remove All Tags',= on a message with a tag, it doesn't work.  The imap keyword still exists.  The gui will remove the color, but the keyword still exists on the server, and the check is still next to the tag on the tag dropdown.

If I uncheck the tag, only then does the imap keyword get removed.  It still remains tagged in the gui however.  Again, only after I rebuild the folder index does the tag finally go away.

So it seems like 'Remove All Tags' doesn't remove the keyword.  And while unchecking the tag does remove the keyword, something isn't getting removed from the message in the index?

Comment 5

12 years ago
*** Bug 350680 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
It occurs for me as well, I use latest Thunderbird 2.0 build under Windows XP. I also use IMAP.
(Reporter)

Comment 7

12 years ago
(In reply to comment #4)
> If I uncheck the tag, only then does the imap keyword get removed.  It still
> remains tagged in the gui however.  Again, only after I rebuild the folder
> index does the tag finally go away.

Original reporter here.  This combination, unchecking the tag and rebuilding the index, works for me, too.  Thanks for the extra info!

Comment 8

12 years ago
this affects SeaMonkey too

this is IMAP-only.  Local folders work ok.

==> IMAP
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Component: General → Networking: IMAP
Ever confirmed: true
OS: Windows XP → All
Product: Thunderbird → Core
QA Contact: general → grylchan
Summary: Unable to consistently remove tags from mail messages → Unable to consistently remove tags from IMAP mail messages
Version: unspecified → Trunk

Comment 9

12 years ago
exactly as described in comment 0. however, rebuild index did not help. Nor did restart TB.  windows XP version 3 alpha 1 (20060926)

Comment 10

12 years ago
Similar: bug 346394. 
(Assignee)

Comment 11

12 years ago
Created attachment 248699 [details] [diff] [review]
proposed fix

I think this is a long standing bug, though it may be that the tag code's attempts to upgrade labels might be involved.

In any case, the problem was that we weren't removing the old label when the server told us that the label had been removed - so, if the server supports the label keywords, and we're told they're not set anymore, remove the label from the header.

I'd love to remove all the label-specific code from imap, but I was scared :-)
Attachment #248699 - Flags: superreview?(mscott)

Comment 12

12 years ago
Comment on attachment 248699 [details] [diff] [review]
proposed fix

heh, I'd be scared too.
Attachment #248699 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 13

12 years ago
fixed on trunk and branch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1.1
Resolution: --- → FIXED

Comment 14

12 years ago
woot!
Keywords: fixed1.8.1.1 → verified1.8.1.1
(Assignee)

Comment 15

12 years ago
*** Bug 359485 has been marked as a duplicate of this bug. ***

Comment 16

10 years ago
This bug seems to have re-appeared in the OS X build of version 2.0.0.14 (20080421).

I have this bug in version 2.0.0.16 for Windows. It happens with IMAP when online, and only with the first tag (Red/Important/1 by default).

Comment 18

10 years ago
Bug 355205 is related.

Several have reported that they can't untag Gmail IMAP messages.  I have several IMAP accounts, and my Gmail account is the only one I experience this issue with (2.0.0.17 on Linux).
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.