tags don't stay removed in the thread pane and Tag drop-down button on IMAP folders

REOPENED
Unassigned

Status

REOPENED
12 years ago
6 years ago

People

(Reporter: myk, Unassigned)

Tracking

(Blocks: 1 bug, {fixed1.8.1})

x86
Linux
fixed1.8.1

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
After upgrading to the latest 2.0 nightly from 1.5, I'm unable to permanently remove tags from tagged emails.  Pressing "0" appears to remove the tag, but if I go to another folder and then return to the one containing the tagged message, the message appears tagged again in the thread pane and the Tag drop-down button on the toolbar.

Strangely, the message preview pane doesn't show the "Tags" header, so the removal appears to have some effect.  Occasionally an attempt to remove a tag will succeed, although it's unclear exactly when and why.  I see the problem both on tags I added before upgrading and those I added after upgrading.  I see it with all three configured IMAP accounts (each one on a different server), but I don't see it with my "Local Folders" account.

Comment 1

12 years ago
Myk, are you using the new mozilla.com IMAP server?

Comment 2

12 years ago
I'm not seeing us even trying to remove the keywords from the messages on the imap server at all anymore...investigating.
Assignee: mscott → bienvenu
(Reporter)

Comment 3

12 years ago
> Myk, are you using the new mozilla.com IMAP server?

I am using that server, and I see the problem there, but I also see this on the old everyone.net IMAP server and the IMAP server at my personal mail provider (pair.com).

Comment 4

12 years ago
Created attachment 241111 [details] [diff] [review]
proposed fix

removeallkeywords was never removing keywords from the server...
Attachment #241111 - Flags: superreview?(mscott)
(Reporter)

Comment 5

12 years ago
> I am using that server, and I see the problem there, but I also see this on 
> the old everyone.net IMAP server and the IMAP server at my personal mail 
> provider (pair.com).

Correction: I now no longer see this on the old everyone.net server, although I do still see this on the new mozilla.com server and the pair.com server.

Perhaps updating to the latest nightly (and restarting to apply the update) prompted this change, or maybe I was mistaken in reporting that the problem occurred with everyone.net.  In any case, I can't reproduce on that server now, but I can reproduce on the other two.

Comment 6

12 years ago
yeah, I wouldn't expect this to be a problem on everyone.net because it doesn't store keywords so it wouldn't matter that we weren't removing keywords from the server in the remove all keywords command case.
Status: NEW → ASSIGNED

Updated

12 years ago
Attachment #241111 - Flags: superreview?(mscott) → superreview+

Comment 7

12 years ago
fixed on trunk and branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Reporter)

Comment 8

12 years ago
I'm still seeing this problem with today's build (version 2 beta 1 (20061006)).  After further investigation, it appears that I can make the tag go away by first pressing 4 (to toggle the tag off) and then pressing 0 (to remove all tags).  Pressing either key by itself doesn't have the desired effect.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

12 years ago
(In reply to comment #8)
> I'm still seeing this problem [...]
>  After further investigation, it appears that I can make the tag go away by
> first pressing 4 (to toggle the tag off) and then pressing 0 (to remove all
> tags).  Pressing either key by itself doesn't have the desired effect.

Bug 348752?
(Reporter)

Comment 10

12 years ago
In tests using the nightly build from 2006-12-01, pressing "0" by itself has started working, but pressing "4" to remove the added tag still doesn't work.
(Reporter)

Comment 11

12 years ago
(In reply to comment #10)
> In tests using the nightly build from 2006-12-01, pressing "0" by itself has
> started working, but pressing "4" to remove the added tag still doesn't work.

Hmm, but pressing "0" by itself still works inconsistently, I'm finding.


(In reply to comment #9)
> Bug 348752?

Yes, it sounds like the two are duplicates.  Not sure which should be duped against the other.  That bug is older, but this bug has had a patch applied.

Comment 12

12 years ago
I'm using version 2 beta 2 (20070116) on Linux and I was able to remove tags by using the 4  0  method. I was not able to remove the tags via the tags menu.

Comment 13

11 years ago
Bug 368210 looks like a duplicate, also see this bug reported against OpenSolaris:

http://bugs.opensolaris.org/view_bug.do?bug_id=6527656

I am experiencing the same problem.  I have messages with tags that I cannot remove at all, trying all combinations of keys 0-5 and tags menu operations.  I can often add new tags and remove them, but there's usually a sticky one that won't go away, which seems to be the first one I add.

I'm using IMAP with GMail.  Contact me if you need more details.

Comment 14

11 years ago
I'm currently running Thunderbird 2.0.0.15pre (20080424) and in the last few builds I've noticed that I cannot remove the "Important" tag from IMAP messages hosted by GMail (I have a gmail hosted domain). Anyone else have this problem?

1. Right-click on a message
2. Tag > Important
(message turns red and the Important tag shows up)
3. Right-click on the message again
4. Tag > Important

Expected: the tag is removed
Actual: the tag is still present (it may disappear from the message detail but if you select another message and come back to this message it says it's important again).

What does work is selecting any other tag (Personal, Work, etc) and removing that... those go on and and off correctly, just the important tag cannot be removed. I also tried "Remove All Tags" and that doesn't fix it either. I tried to right-click on the folder and selected "rebuild index" and that still didn't remove the tag. So is this a google problem, or is Thunderbird not removing the appropriate header for the important tag (perhaps GMail rewrites a different header field when Thunderbird sets the important tag in the standard X-Mozilla-Keys field???)....
Blocks: 432710

Comment 15

10 years ago
I am running Thunderbird 2.0.0.14 (20080421) and just found that I am unable to remove the "Important" tag from IMAP messages hosted by GMAIL. Exactly as in the description from comment #14

Comment 16

10 years ago
Same here with version 2.0.0.18
But the bug is more likely caused by Gmail and their IMAP support as I never encountered this bug using other IMAP servers.
I'll try using another client to confirm that though.

Comment 17

10 years ago
seams same there, for gmail imap, but only in label1 (important)
http://groups.google.com/groups?selm=3sSdnc75nYmGlqrUnZ2dnUVZ_uSdnZ2d%40mozilla.org

variations and related:
bug 368210 (mentioned before), bug 440951), bug 426651


cannot repro myself as not using imap on tb2
wfm in 3.0b1, gmail imap and others

Comment 18

9 years ago
Still seeing this on 3.0RC.

Comment 19

9 years ago
I just tried this out on 3.0 RC 1 Build 3 and it appears to be working just fine.   I previously had a problem with this in 2.0.x though.

Comment 20

9 years ago
Using current nightly, updated today.  Still occurs.  But turns out this is a duplicate of 440951, which is listed in the Gmail IMAP meta-bug.

Updated

6 years ago
Assignee: dbienvenu → nobody
You need to log in before you can comment on or make changes to this bug.