Search plugin with port in action URL does not retain port when search terms are empty

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

With a search plugin where the action URL includes a (non-80) port, hitting Enter while in the search box and no search terms will attempt to load the URL without the port.

Reproducible: Always
Can you try a 1.8 branch build, like Bon Echo beta 1, or a 1.8 branch nightly, and report back on whether this now works or not? Any build from ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8 would do.
(Reporter)

Comment 2

12 years ago
It looks like what the searchplugin feature does when there are no terms in the submitted search box is to take the user to the base URL portion of the action URL. When it does this, it is not including the port. (Could it be a bad RE?)

A better solution might be to include a "default-url" parameter to the searchplugin format to serve as the URL to load in that use case, instead of (or to override) having to relying on an RE and/or a valid base URL.
(Reporter)

Comment 3

12 years ago
(In reply to comment #1)
> Can you try a 1.8 branch build, like Bon Echo beta 1, or a 1.8 branch nightly,
> and report back on whether this now works or not? Any build from
> ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla1.8 would
> do.
> 

Will try WIGAC.
Ah, yes. The new search service (that will be in Firefox 2) uses the SearchForm attribute of the new XML search plugins to provide a customizable default URL. See the "SearchForm" description at http://developer.mozilla.org/en/docs/Creating_MozSearch_plugins . The equivalent attribute for Sherlock plugins is the searchForm attribute, see http://mycroft.mozdev.org/deepdocs/searchtag.html#searchForm.

Comment 5

12 years ago
As a by the way, this is effectively a duplicate of bug 322934
Am very glad that the s/SearchForm is being used in future
(what happens if it's not defined? back to the old behaviour? I'll have a look later)
Since bug 325913 was fixed, search plugins can specify the exact URL for blank searches, so I'm marking this WORKSFORME.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.