"Reload All Live Titles" and "Reload All Live Titles" in a folder

RESOLVED WONTFIX

Status

P4
enhancement
RESOLVED WONTFIX
12 years ago
3 years ago

People

(Reporter: me, Unassigned)

Tracking

({helpwanted, uiwanted})

unspecified
Future
helpwanted, uiwanted

Details

(Whiteboard: [microsummaries-feature-removal])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060817 BonEcho/2.0b1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060817 BonEcho/2.0b1

It would be nice to see a "Reload All Live Titles" in the context menu when right-clicking on a live title then when clicked reloads all the Live Titles a user has.  Then, if a user right clicks on a folder containing one or more live titles, there should be a "Reload All Live Titles" in the context menu that when clicked reloads all the Live Titles in the folder.

Reproducible: Always

Actual Results:  
User has to manually reload Live Titles one by one.

Expected Results:  
User can do this:

(a): right click on a live title, see "Reload all Live Titles", click it, and all live titles are reloaded.
(b): right click on a folder containing one or more live titles, see "Reload all Live Titles", click it, and all live titles in the corresponding folder are reloaded.

*** This bug has been marked as a duplicate of 338118 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Why do you refer to microsummaries as "live titles"? Is that what they're supposed to be called now? People confuse it with "live bookmarks" too easily, IMO.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(In reply to comment #2)
> Why do you refer to microsummaries as "live titles"? Is that what they're
> supposed to be called now? People confuse it with "live bookmarks" too easily,
> IMO.

Microsummaries are short summaries of web pages.  When microsummaries are used to label bookmarks (which is the only way they're currently used but not the only way they could be used), the labels are called live titles, which is intentionally similar to "live bookmarks", since they do similar things (i.e. make a bookmark "live").
When I was asking Beltzner about the livemark version of this the other day, he said (roughly) that a context menu item that acts on "everything like this in the same container" is ok, but not one that acts on "everything like this whether or not I can see it at the moment." So, a "Reload all in this folder" on an individual one, yes, but not a "reload every one everywhere." 
Keywords: uiwanted
(Reporter)

Updated

12 years ago
Keywords: helpwanted

Updated

10 years ago
Status: REOPENED → NEW
Priority: -- → P4
Target Milestone: --- → Future
- BUGSPAM -
Wontfixing all Microsummaries bugs, since the feature has been removed from the core product and previous versions won't get further fixes for it.
If interested in supporting Microsummaries in your add-on, you're free to use our old microsummaries code and to search all previously open bugs by looking for [microsummaries-feature-removal] in the status whiteboard field.
Status: NEW → RESOLVED
Last Resolved: 12 years ago8 years ago
Resolution: --- → WONTFIX
Whiteboard: [microsummaries-feature-removal]
(Assignee)

Updated

3 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.