cannot add rss or atom feeds anymore in TB 2.0: subscribe hangs on "verifying the RSS feed"

VERIFIED FIXED

Status

MailNews Core
Feed Reader
VERIFIED FIXED
12 years ago
9 years ago

People

(Reporter: Jean-Michel Reghem, Assigned: Bienvenu)

Tracking

({fixed1.8.1, regression})

1.8 Branch
fixed1.8.1, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

12 years ago
TB 2.0a1 2006082005 (but problem appairs for me on a previous build last week)

--> when i try to add a rss or atom feed, TB try to verifying the link, but never finish (neither "unvalid feed" or "downloading articles") --> i have to press "stop". 
--> a dialog box appairs ("would you like to cancel verifying feed?") and the same result come if i press "yes" or "no"

--> the feed seems present (i can drag and drop to a subfolder) ... but it doesn't work and new post are not downloaded ...
--> by checking the list of post in "subscribe", i've seen that there is a feed entry, but there is no url associated with this


I've post a comment on this bug https://bugzilla.mozilla.org/show_bug.cgi?id=332910#c5 ... believing that the feed http://blogs.msdn.com/texttospeech/atom.xml had problems ...

But today, with this feed: http://www.fleurblog.com/atom.php  (or http://www.fleurblog.com/rss.php) the feed is valid ( http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fwww.fleurblog.com%2Fatom.php )

I let this bug to UNCONFIRMED state and not NEW, as i don't know if this is a bug in the last 2.0a code or if my configuration is broken ...
(Reporter)

Comment 1

12 years ago
Created attachment 234766 [details]
subscribe dialog box

The feed "Fleur Blog" after cancelling "verifying the rss feed" and moving it to a subfolder ...
Unlike other feed, there is no " location feed item" attach to this feed

--> it is always the same for all new feed i want to add
(Reporter)

Comment 2

12 years ago
bug 332910 refers to a invalid feed (title element empty, etc ...)
bug 297569 is for feed with emty link

here, the feeds are valid ...
(Reporter)

Comment 3

12 years ago
workaround: see images in attachement:
1)Cancelling verification
2)Eventually move the wrong empty feed to the wanted subfolder
3)Subscribe --> Add
4)Choose the previous entered feed container as location and re-paste the url feed
5)--> now, the feed verifying correctly and articles are downloaded
(Reporter)

Comment 4

12 years ago
Created attachment 234767 [details]
Workaround: re-adding manually the feed to the desired location
(Reporter)

Comment 5

12 years ago
Created attachment 234768 [details]
And voilà ...
(Reporter)

Comment 6

12 years ago
This workaround works with all other last feeds i've tried to enter "classically" and which hangs ...
http://blogs.msdn.com/robertbrown/atom.xml
http://blogs.msdn.com/texttospeech/rss.xml
http://blogs.msdn.com/sprague/atom.xml
http://blogs.msdn.com/robch/atom.xml


strange that with this way, the validity is OK and the posts are downloaded, and with the normal quick methode (add feed in root News and Blogs folder) is is not working

Comment 7

12 years ago
Interesting.  I also see this problem with the FleurBlog RSS and the robertbrown/atom feeds, with 2a1-0817 and 3a1-0816; the subscription process creates the folder but otherwise never completes.  feedvalidator.org says the feed is completely valid.  Firefox has no problem using that same URL as a live bookmark; starting TB 1.5 and retrying the URLs works with no problems.

(NB: the first article I looked at in FleurBlog feed was a bit prurient.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-thunderbird2?

Comment 8

12 years ago
Linux too. Get this in the error console:

Error: [Exception... "Cannot modify properties of a WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)"  location: "JS frame :: chrome://messenger-newsblog/content/FeedItem.js :: anonymous :: line 388"  data: no]
Source File: chrome://messenger-newsblog/content/FeedItem.js
Line: 388
Keywords: regression
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 9

12 years ago
I've found that drag dropping a feed url into the folder pane works, but adding the url via the subscribe ui doesn't. I suspect my recent change to feeditem.js is responsible - I'll look for a fix. Perhaps we don't have the folder yet, or something...
(Assignee)

Comment 10

12 years ago
Created attachment 235492 [details] [diff] [review]
this fixes the problem

apparently, in this situation, this.folder isn't an nsIMsgFolder, so doing a QI fixes the problem...not sure if there's a better fix.
Assignee: mscott → bienvenu
Status: NEW → ASSIGNED
Attachment #235492 - Flags: superreview?(mscott)

Comment 11

12 years ago
Comment on attachment 235492 [details] [diff] [review]
this fixes the problem

I can't think of a better way.
Attachment #235492 - Flags: superreview?(mscott) → superreview+

Comment 12

12 years ago
It crashes when "RSS Subscription" window is shut because the subscription to RSS is not completed. 

TB22559269E

Mac OS X 10.3.9
version 2 alpha 1 (20060826)

Comment 13

12 years ago
Created attachment 235635 [details]
Talkback log

Comment 14

11 years ago
David did this patch get checked in on the trunk and branch already? 
(Assignee)

Comment 15

11 years ago
yes, fix was checked in a few days ago, sorry about that - fixed on trunk and branch
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Updated

11 years ago
Status: RESOLVED → VERIFIED

Comment 16

11 years ago
clearing blocking flag on a fix which has already landed on the branch.
Flags: blocking-thunderbird2?

Comment 17

11 years ago
I have problem again in Gecko/20070515 Firefox/2.0.0.4

--> when i try to add a rss or atom feed, TB try to verifying the link, but
never finish (neither "unvalid feed" or "downloading articles") --> i have to
press "stop". 
--> a dialog box appairs ("would you like to cancel verifying feed?")

but no folder is being created

Updated

9 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
Version: 2.0 → 1.8 Branch
You need to log in before you can comment on or make changes to this bug.