Offline news: line beginning with '.' stored & displayed with '..'

RESOLVED DUPLICATE of bug 170727

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 170727
11 years ago
9 years ago

People

(Reporter: Julien ÉLIE, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

When the articles of a news server are sent to Thunderbird in wireformat (that is to say in NNTP format), they are not saved to the disk in the right Thunderbird format.
Indeed, if an articles has a line with a single dot « . », it is well displayed the first time I see the article.  But it is saved to the disk, in the Thunderbird newsbox, as « .. ».  Then, if I reopen Thunderbird and read the article (locally saved), it displays « .. » (and not « . », as I still can see in the source of the article [Ctrl+U]).


Reproducible: Always




I believe Thunderbird should always save the article in its own format (and not in wireformat when the article is sent in this format).

Comment 1

11 years ago
Why, so it does.  (I just put a couple sample messages in mozilla.test, but it's plenty easy to reproduce.)  I'm refiling this under MailNews:Backend; there is a MailNews:Offline component, but it's located under Suite rather than Core.

Note: it's not possible to   View|Message Source   for an offline news message 
-- but there's already a bug for that, bug 128297.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → MailNews: Backend
Ever confirmed: true
OS: Windows XP → Windows 2000
Product: Thunderbird → Core
QA Contact: front-end → offline
Summary: Local copy of news articles are not in a good NNTP format. → Offline news: line beginning with '.' stored & displayed with '..'
Version: unspecified → Trunk

Comment 2

11 years ago
This looks like bug 170727 to me...

Comment 3

11 years ago
I agree, duping.

*** This bug has been marked as a duplicate of 170727 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.