Strict warning: Expected color but found 'null'. (in editCategory.xul)

RESOLVED FIXED in 1.0b2

Status

Calendar
General
--
trivial
RESOLVED FIXED
12 years ago
8 years ago

People

(Reporter: Damian Szczepanik, Assigned: Fallen)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060823 Calendar/0.3a2+

warning when you set or modify color of category

Reproducible: Always

Steps to Reproduce:
1. open tools -> options -> categories
2. select category and press edit
3. modify color and close  "edit category" dialog (press ok)

Actual Results:  
error console:

Warning: Expected color but found 'null'.  Error in parsing value for property 'background-color'.  Declaration dropped.
Source File: chrome://calendar/content/preferences/editCategory.xul
Line: 0


warning appears but except this - works fine
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk

Comment 1

12 years ago
Should be fixed with the patch in Bug 350319 too.
Status: UNCONFIRMED → NEW
Depends on: 350319
Ever confirmed: true

Updated

12 years ago
Summary: warning in parsing when set color of category → Strict warning: Expected color but found 'null'. (in editCategory.xul)

Updated

12 years ago
Assignee: nobody → ssitter
OS: Windows XP → All
Hardware: PC → All

Updated

12 years ago
Status: NEW → ASSIGNED

Updated

11 years ago
Duplicate of this bug: 370544
This wasn't fixed with the patch in Bug 350319.

Tested with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3pre) Gecko/20070308 Calendar/0.5pre.

Comment 4

11 years ago
(In reply to comment #3)
This is correct, see Bug 350319 Comment #5.
No longer depends on: 350319

Updated

11 years ago
Assignee: ssitter → nobody
Status: ASSIGNED → NEW

Comment 5

10 years ago
Still present in the latest nightlies.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021519 Calendar/0.6a1
(Assignee)

Comment 6

8 years ago
Created attachment 432666 [details] [diff] [review]
Fix - v1
Assignee: nobody → philipp
Status: NEW → ASSIGNED
Attachment #432666 - Flags: review?(mschroeder)
Comment on attachment 432666 [details] [diff] [review]
Fix - v1

r=mschroeder
Attachment #432666 - Flags: review?(mschroeder) → review+
(Assignee)

Comment 8

8 years ago
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/f0b251ece684>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.0b2
You need to log in before you can comment on or make changes to this bug.