Last Comment Bug 350081 - ASSERTION: invalid number of columns
: ASSERTION: invalid number of columns
Status: RESOLVED FIXED
: fixed1.8.0.7, fixed1.8.1, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: Bernd
:
:
Mentors:
Depends on:
Blocks: stirtable
  Show dependency treegraph
 
Reported: 2006-08-24 12:09 PDT by Bernd
Modified: 2006-09-10 10:42 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (443 bytes, text/html)
2006-08-24 12:11 PDT, Bernd
no flags Details
patch (1.56 KB, patch)
2006-08-24 12:17 PDT, Bernd
bzbarsky: review+
bzbarsky: superreview+
Details | Diff | Splinter Review
another case where it asserts (476 bytes, text/html)
2006-08-25 23:24 PDT, Bernd
no flags Details
revised patch (9.46 KB, patch)
2006-08-25 23:26 PDT, Bernd
bzbarsky: review+
bzbarsky: superreview+
dveditz: approval1.8.0.7+
mbeltzner: approval1.8.1+
Details | Diff | Splinter Review

Description User image Bernd 2006-08-24 12:09:47 PDT
see testcase
Comment 1 User image Bernd 2006-08-24 12:11:04 PDT
Created attachment 235279 [details]
testcase
Comment 2 User image Bernd 2006-08-24 12:17:39 PDT
Created attachment 235281 [details] [diff] [review]
patch
Comment 3 User image Bernd 2006-08-25 23:24:15 PDT
Created attachment 235537 [details]
another case where it asserts
Comment 4 User image Bernd 2006-08-25 23:26:16 PDT
Created attachment 235538 [details] [diff] [review]
revised patch

The change from the previous patch also needs to be done in AppendCells.
Comment 5 User image Bernd 2006-08-25 23:27:15 PDT
Boris if you could propose a better name I am happy to follow.
Comment 6 User image Bernd 2006-08-26 08:44:18 PDT
Comment on attachment 235538 [details] [diff] [review]
revised patch

this revises the patch for bug 347725
Comment 7 User image Mike Schroepfer 2006-08-27 10:14:24 PDT
Comment on attachment 235538 [details] [diff] [review]
revised patch

Thanks for working on this!  Clearing 1.8.1 flags since reviews are not complete.  Please get the reviews complete, land on trunk, and then re-request 1.8.1 approval.
Comment 8 User image Boris Zbarsky [:bz] (still a bit busy) 2006-08-27 13:39:02 PDT
Comment on attachment 235538 [details] [diff] [review]
revised patch

>Index: nsTableFrame.cpp
>+nsTableFrame::MatchCellMapToColCache()
>+{
>+  nsTableCellMap* cellMap = GetCellMap();

Why get it up front here instead of where it's needed?

Either move this to the one spot in this function where we use it, or pass an nsTableCellMap as an arg.

r+sr=bzbarsky with that
Comment 9 User image Daniel Veditz [:dveditz] 2006-08-28 10:30:00 PDT
Comment on attachment 235538 [details] [diff] [review]
revised patch

approved for 1.8.0 branch, a=dveditz for drivers with bz's comment incorporated
Comment 10 User image Bernd 2006-08-28 11:22:11 PDT
fixed on trunk with bz comment (I went for the arg)
Comment 11 User image Bernd 2006-08-28 11:22:53 PDT
Comment on attachment 235538 [details] [diff] [review]
revised patch

I would like to take this onto 1.8.1 too
Comment 12 User image Mike Beltzner [:beltzner, not reading bugmail] 2006-08-28 15:05:26 PDT
Comment on attachment 235538 [details] [diff] [review]
revised patch

a=beltzner for 1.8.1drivers with bz's comments incorporated.
Comment 13 User image Bernd 2006-09-01 12:01:17 PDT
fixed on 1.8.1

Note You need to log in before you can comment on or make changes to this bug.