Cairo-related linker warnings with VC8

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

(Blocks 1 bug)

Trunk
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [build_warning])

Recently when doing trunk compiles with VC8, I've gotten a series of warnings as shown below:

gkgfxthebes.lib(nsThebesRenderingContext.obj) : warning LNK4049: locally defined symbol ??0gfxContext@@QAE@PAVgfxASurface@@@Z (public: __thiscall gfxContext::gfxContext(class gfxASurface *)) imported
gkgfxthebes.lib(nsThebesRenderingContext.obj) : warning LNK4049: locally defined symbol ?CurrentMatrix@gfxContext@@QBE?AVgfxMatrix@@XZ (public: class gfxMatrix__thiscall gfxContext::CurrentMatrix(void)const ) imported
gkgfxthebes.lib(nsThebesRenderingContext.obj) : warning LNK4049: locally defined symbol ?GetPlatform@gfxPlatform@@SAPAV1@XZ (public: static class gfxPlatform *__cdecl gfxPlatform::GetPlatform(void)) imported
gkgfxthebes.lib(nsThebesRenderingContext.obj) : warning LNK4049: locally defined symbol ?Paint@gfxContext@@QAEXN@Z (public: void __thiscall gfxContext::Paint(double)) imported
gkgfxthebes.lib(nsThebesRenderingContext.obj) : warning LNK4049: locally defined symbol ?SetOperator@gfxContext@@QAEXW4GraphicsOperator@1@@Z (public: void __thiscall gfxContext::SetOperator(enum gfxContext::GraphicsOperator)) imported
gkgfxthebes.lib(nsThebesImage.obj) : warning LNK4049: locally defined symbol ??1gfxImageSurface@@UAE@XZ (public: virtual __thiscall gfxImageSurface::~gfxImageSurface(void)) imported
gkgfxthebes.lib(nsThebesImage.obj) : warning LNK4049: locally defined symbol ?SetSource@gfxContext@@QAEXPAVgfxASurface@@UgfxPoint@@@Z (public: void __thiscall gfxContext::SetSource(class gfxASurface *,struct gfxPoint)) imported
gkwidget.lib(nsNativeThemeWin.obj) : warning LNK4049: locally defined symbol ?CurrentSurface@gfxContext@@QAE?AU?$already_AddRefed@VgfxASurface@@@@PAN0@Z (public: struct already_AddRefed<class gfxASurface> __thiscall gfxContext::CurrentSurface(double *,double *)) imported
gkwidget.lib(nsNativeThemeWin.obj) : warning LNK4049: locally defined symbol ?UpdateSurfaceClip@gfxContext@@QAEXXZ (public: void __thiscall gfxContext::UpdateSurfaceClip(void)) imported

I'm not sure when this regressed as I was having problems that kept me from building for a few weeks.
*** Bug 353490 has been marked as a duplicate of this bug. ***
Summary: Cairo-related compiler warnings with VC8 → Cairo-related linker warnings with VC8
Vlad: dunno what you wanted this to depend on, but it doesn't depend on bug 351565 :)
No longer depends on: 351565
Blocks: buildwarning
Whiteboard: [build_warning]
This is gone.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.