Phishing Protection does not display warning bubble when local list used

RESOLVED FIXED in Firefox 2

Status

()

Toolkit
Safe Browsing
--
major
RESOLVED FIXED
11 years ago
3 years ago

People

(Reporter: reed, Assigned: Tony Chang (Google))

Tracking

({fixed1.8.1, regression})

2.0 Branch
Firefox 2
fixed1.8.1, regression
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
Well, it seems phishing protection was broken sometime over the last couple of days. When I go to Google Safe Browsing Test Page now, I do not get any type of bubble when using the "Check using a downloaded list of suspected sites" option. When I choose "Check by asking Google about each site I visit," the warning bubble appears again. When I swap back to the default option, the bubble does not display.

Error: this.listManager_ has no properties
Source File: file:///C:/Program%20Files/Bon%20Echo/components/nsSafebrowsingApplication.js
Line: 2160
(Reporter)

Updated

11 years ago
Flags: blocking-firefox2?
(Reporter)

Comment 1

11 years ago
*** Bug 350459 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

11 years ago
Assignee: nobody → tony
(Assignee)

Comment 2

11 years ago
Can you try some urls on this list (what's being downloaded):
http://sb.google.com/safebrowsing/update?client=navclient-auto-ffox&version=goog-black-url:1:-1

This is a bug where the test pages are only being checked in remote lookup mode. I'm not sure when it regressed, I think that the phish-o-rama page was recently removed from the blacklist.

Not sure about the exception, I'll look into that today.
(Assignee)

Comment 3

11 years ago
(In reply to comment #2)
> This is a bug where the test pages are only being checked in remote lookup
> mode. I'm not sure when it regressed, I think that the phish-o-rama page was
> recently removed from the blacklist.

Also, there's a fix for this on bug 349102.
Flags: blocking-firefox2? → blocking-firefox2+
http://labachelor.com/www.paypal.com/cgi-bin/primapagina.htm pulled up the phishing dialog

http://lfpalszliiix.info/ didn't, I guess cuz it redirects to http://www.paypal.com.lfpalszliiix.info/webscr.php?cmd=LogIn ?

http://montevia.el-monte.net/firma/ pulled up the dialog even though the server was not found, pretty cool.

so looks like it's just the test page - http://www.google.com/tools/firefox/safebrowsing/phish-o-rama.html

Although this DID work - http://www.google.com/tools/firefox/toolbar/FT2/intl/en/phish-o-rama.html
(Assignee)

Comment 5

11 years ago
I'm wrong.  This was regressed in bug 348625 patch "use whitelist to suppress remote lookups."  This went in after the b2 freeze.
(Assignee)

Comment 6

11 years ago
Fixed by the patch on bug 349102.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.