Can't type in message compose body; sMsgComposeService is not defined

VERIFIED DUPLICATE of bug 351057

Status

--
blocker
VERIFIED DUPLICATE of bug 351057
12 years ago
10 years ago

People

(Reporter: stephend, Unassigned)

Tracking

({regression, smoketest})

Trunk
x86
Windows XP
regression, smoketest

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Build ID: 2006-09-01-07 of SeaMonkey trunk, as well as version 3 alpha 1 (20060901) of trunk Thunderbird.

Summary: Can't type in message compose body; sMsgComposeService is not defined.

This is a smoketest blocker.

Also, the compose window type doesn't matter; that is, HTML and plain text are both broken.

Not sure if this is a regression from bug 350846.  My apologies for the erroneous cc if it's not, smaug.

Steps to Reproduce:

1. Click New Msg in SeaMonkey or Write in Thunderbird.
2. Type a recipient and/or subject, and/or tab through to the body.
3. Try to type.

Expected Results:

Able to type.

Actual Results:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgCompose.initEditor]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: InitEditor :: line 3317"  data: no]
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 3317
Error: sMsgComposeService is not defined
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 1081
*** Bug 351054 has been marked as a duplicate of this bug. ***
(In reply to comment #2)
> Backing out bug 350846 doesn't seem to help here.
> 

I tested only thunderbird.
(Reporter)

Comment 4

12 years ago

*** This bug has been marked as a duplicate of 351057 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.