Switching between "Show preview" and "Subscribe to the Feed" doesn't show the correct Livebookmark title

VERIFIED DUPLICATE of bug 348227

Status

()

Firefox
RSS Discovery and Preview
VERIFIED DUPLICATE of bug 348227
12 years ago
12 years ago

People

(Reporter: marcia, Unassigned)

Tracking

2.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Pretty minor but, but filing it anyway. Seen using Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060901 BonEcho/2.0b2

STR:

1. Open a few tabs.
2. Check the pref to "Show me a preview every time".
3. Add a feed (http://www.nytimes.com/services/xml/rss/nyt/Arts.xml) by pasting the feed URL into the URL bar. Add the feed as a Livebookmark.
4. Go back into Preferences and change the preference to "Subscribe to the feed using Livebookmarks"
5. In the same tab, cut and paste a new feed and put it in the URL. Submit.
6. The bookmark dialog that comes up shows the incorrect feed title in it - it will always show you the title of the last feed you just added.
Component: Bookmarks → RSS Discovery and Preview
QA Contact: bookmarks → rss.preview
(Reporter)

Comment 1

12 years ago
I showed this to Seth, he pointed out that Firefox is pulling the name of the page and using it as the bookmark title.
(In reply to comment #1)
> I showed this to Seth, he pointed out that Firefox is pulling the name of the
> page and using it as the bookmark title.

Ah, so possibly fixed by bug 348227 (which isn't on the branch yet)?
Yep, this is a very good and intricate way to get into the situation that bug 348227 solves: a page title that has nothing whatsoever to do with the feed being added. In a trunk build, at step 6 the added livemark (since trunk doesn't have a dialog) gets it's own title from the feed, rather than the title from the previous feed preview that's still showing.

*** This bug has been marked as a duplicate of 348227 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.