HP-UX Unsatisfied symbols: JSAutoTempValueRooter

RESOLVED DUPLICATE of bug 347504

Status

()

Core
Build Config
--
major
RESOLVED DUPLICATE of bug 347504
12 years ago
4 years ago

People

(Reporter: Stefan Blobner, Unassigned)

Tracking

1.8 Branch
Other
HP-UX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.8.1b2) Gecko/20060905 Firefox/2.0b2

building Firefox 2.0 b2 on HP-UX, the build fails with:

/usr/ccs/bin/ld: Unsatisfied symbols:
   static JSAutoTempValueRooter::operator delete(void *,unsigned long) (first referenced in ../../dist/lib/components/libgkplugin.a(ns4xPlugin.o)) (code)

while linking firefox-bin.

Searching for 'JSAutoTempValueRooter', I only find the references in './modules/plugin/base/src/ns4xPlugin.cpp' line 1737 and './modules/plugin/base/src/nsJSNPRuntime.cpp' line 674. then there is the header file './js/src/jscntxt.h', but no implementation anywhere.

so it looks like this is either missing, or the references in the code should be removed.

Reproducible: Always

Steps to Reproduce:
1. build on HP-UX
compare bug 347054 comment 21

the reason for the lack of implementation is that this class is not supposed to be heap-allocated and thus there should be no reference to operator delete...

> or the references in the code should be removed.

there is no reference
Component: Build Config → Build Config
OS: Other → HP-UX
Product: Firefox → Core
QA Contact: build.config → build-config
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

12 years ago
the reference to bug 347054 comment 21 helped. so you can mark this defect a duplicate of that one.
Marking as per comment 2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 347504
You need to log in before you can comment on or make changes to this bug.